APM Mini 3.1 pinout

I recently purchased an APM mini 3.1 from goodluckbuy.com. I also purchased the external GPS with compass. (goodluckbuy.com/miniapm-v3-1 … opter.html) I’m trying to figure out the pinout on both the GPS/compass board as well as the APM Mini board so that I can wire both up. Does anyone have a diagram of both board’s pinout so that I can finish wiring it?


Try here:


Hope you have better luck than me. I bought two of these, both d.o.a. On both of them the board is not passing the pwm to all the motor pin outs on both boards. On one only 4 work, on the other, five. Waste of £60

Also, if you make the JP2 connection to allow it to be powered via a bec on the motor pins you will not be able to upgrade firmware. Heaven knows how and why. If you are not using a power module and you want to be able to upgrade firmware leave jp2 open and run the power to the pm port pins. Double up both + ve and - ve

Interested how you get on.

Although the board is clearly targeted at the mini-quad crowd, and I had originally ordered mine to try on a mini-quad, I thought it would make a good board for a trainer plane I had. Now I’m not sure if it works with Arduplane at all. To be perfectly clear, this is the 30 mm x 30 mm square clone APM “3.1” board I am talking about.

goodluckbuy.com/miniapm-v3-1 … r-fpv.html

Putting together the relevant custom cables was tedious, but during my build everything seemed to work, until I reached the point of getting servos connected. Once the board goes through the first few seconds of booting, whatever servo I have connected to the first 4 motor outputs thrashes randomly and violently. I tried the second of my two boards, same result. I made sure I was NOT in any of the controlled flight modes. This happens when the board is in Manual, no failsafe, as well as any controlled flight mode.

I tried installing ArduCOPTER to see if the servos would behave any different, and while I did not do a full install on a quad, it did appear to be doing something more reasonable, with full deflection of the surfaces of my plane rather than random thrashing. That at least makes me think it a software fix is possible, and that this bad interaction is limited to Arduplane (which the Asian board designers probably did not care about).

All suggestions appreciated. I’m actually happy to contribute to the code if I can, but I’m unsure where to start analyzing this problem. Do I need to examine the output electrically on a scope? Something else? Is this known / recognizable issue?

I was thinking of buying one of these APM Mini 3.1 boards + gps too, to put it on a small foam plane…

Did anyone manage to get it working with planes?