Servers by jDrones

APM Loiter/Auto Issue's

Having Issues with my apm 450 quad in loiter and auto modes. It seems like it is either over correcting or the GPS / Baro is moving around and giving off inaccurate readings. I have a video to show what it looks like and I have tried a few different things with no luck. It flies pretty much perfect in stabilize mode.

-Tried Calibrating Compass (At Least 4 Times)
-Tried Auto Tuning The Quadcopter
-Tried Calibrating Accelerometer / Level
-Made Sure That Correct Compass Is Being Used
-Getting 10-12 Sats Inside Of House
-Added Foam To Baro Inside APM 2.8

Set Up:
-APM 2.8
-F450 Frame
-SunnySky 980kv Motors
-4in1 ESC
-Beitan GPS

I would really appreciate if anyone could make some suggestions. Thanks,
(Sorry for the crappy video :grin:)
Edit: In the video, I took the quadcopter off in stabilize and switched it to loiter. It had been on for a minute or two beforehand so should have a good GPS lock. I left the controls completely still while it was in loiter and then landed in stabilize at the end. I am also not sure if the log provided is the same as in the video but it should still show the issue.
Log.zip (94.7 KB)

You have so little logging turned on it’s a bit hard to determine what’s wrong.

At least have IMU, RCout, and a few others to help see what the problem might be.

Okay here is a new log with more info turned on. I had it in loiter for a bit longer aswell.
2ndLog.zip (981.8 KB)

As I suspected, in a word, vibration.

You will need to get the levels of vibration down. That will be causing all sorts of stabilisation issues.
Its probably causing most of these issues

Once sorted an autotune would help.

Thanks so much. I put on a vibration dampener and it has helped a ton. I am now playing with auto missions!

Servers by jDrones