Servers by jDrones

APM:Copter V3.5.1 Quad 2 problems

(Mike Gauthier) #1

I have a PIXHAWK running APM:Copter V3.5.1 Quad connected to the windows Mission Planner version 1.3.49 build 1.1.6410.20232 APM:Copter 3.5.1 and there are multiple problems with the Config Wizard.

The second compass is not working. I tried to use a different GPS/Compass but neither one makes a difference. I have both compasses selected but only compass #1 is working when calibrating.

2: When I get finished with all the configuration steps It asks if the drone can be armed but it also says the accelerometer config requires a reboot. I cannot arm the drone in this state and If I reboot, the com connection is broken and cannot be reconnected while in the wizard. The wizard is stuck in this mode and I need to use the windows task manager to stop the mission planner.

Finally, if I ignore the reboot and just try to tell it that it was armed ok, it does not save the configurations that I just completed. The same problem exists if I go through the mandatory hardware setup.

This all means I cannot configure my drone.

(Igor) #2

I never used the wizard. The first time I tried it long time ago my quad was a mess. I never looked back.
Just do all the mandatory and/or optional setup steps, based on what equipment you have on the quad and you will be good to go.
After your first flight, do the autotune (one axis at a time) and enjoy.

(Mike Gauthier) #3

Okay, I found the problem with the 2nd compass. It helps if you plug it into GPS and I2C, not GPS and CAN.

I am configuring everything without the wizard now.

Have to find out what the IGOR means by autotune

(Igor) #4

Here you will find everything about it:

(Mike Gauthier) #5

Thanks IGOR I appreciate the pointer. I will read about that and start the autotune process.

Before I run autotune, the copter flies okay but drifts pretty hard to the left and forward in stabilize mode. Does autotune fix that or is there a different procedure to trim drift?

(Igor) #6

In stabilize the copter should be stable and not drifting in any direction.
First, check if there is any trim on your radio set up, if it is, clear all the trims. APM doesn’t like any trims.
Have you calibrated your ESC’s?
If no, do it now.
Also, check your center of gravity, although I don’t think its an issue here, the FC should compensate.

Check the above before starting the autotune!

It would be good if you upload your flight logs here (.bin) or dropbox and post a link. A short flight in stabilize will do.

(Mike Gauthier) #7

All the DX8 Trims are set to 0 and the mechanical trim buttons are disabled in copter mode. The ESC’s have been calibrated. CG is good too.

I found a document that talks about AUTO TRIM. In order to use that, I have to switch the DX8 to Airplane mode so the trim buttons will work.This drone needs some work to fly reasonably steady in stabilize mode.

(Igor) #8

I am not familiar with the DX8, but have you turned off all the mixing in the radio?
And please post your log, like this we are shooting in the dark…

(Mike Gauthier) #9

Ok, here is the log from this morning. The DX8 is now in Airplane mode and the trims have been saved to the Pixhawk. I added a little more trim this morning and it is pretty steady with only occasional slow drift (probable the breeze).

Hope this log helps.