APM Cannot save waypoint

Hi all,

So I am having this weird problem. I cannot save waypoint using the CH7 or CH8. The GPS have good coverage (7+ sats) and everything works great, just the Save WP trigger. The receiver also works fine. 1800+ PWM

Any advice would be great

Not sure if this feature is tested in the current release. I’ll ask.

I’ve used it in previous versions before (2.8, 2.9).

And I don’t think it was turned off. Just now after leaving the drone on for 30+ mins and playing around with the Aux. Channel settings on the remote and CH7 & CH8 opt settings in mission planner. It just worked… I was able to save waypoint again. But after restarting the APM, the problem came right back. :neutral_face:

Some updates on this. I believe it has something to do with my settings. Since I tried it on three different APMs (2.5) with the latest firmware versions and mission planner. It has the same result. Anyone?

Save waypoint is part of our autotest. It should be working in all recent versions of AC. Can you post a log of several waypoints being saved?