APM 3.6 Flight Mode Initializing Issue

recently i bring out my 3dr apm board 2.6 with external gps and i want to make my skywalker x8 fly again. Then i download latest mission planner (not apm2 planner) and flash the board with latest firmware (3.6).
All done but when i connect the board and try to change flight mode i see only “INITIALIZING” and QLoiter, QRTL, Q…something. If then i connect my board to APM2 Planner i can see all flight modes. But i don’t like so much APM2 Planner… Another issue is when i try to do Compass Motor calibration i get error when i push start and cannot do calibration. All other initial configuration found. I try to fly four times and using stabilize and auto mode and all is perfect. So i think apm 3.6 cannot connect to mission planner. Is correct? Can i get back using Mission Planner instead APM2 Planner?

Thanks and sorry for lame question.

Hi Codeforge
From what I understand APM2 is only supported up to version 3.4:

I’m surprised it let you install 3.6. Try 3.4, maybe that will work.

yeas how come it installed a px4 fw lolz, those q stuff are for quad plane para

Did you solve it?? I have the same issue =(

If you check the firmare you loaded is 3.4. I’m sure you selected 3.6 but the MP load 3.4 instead of 3.6 since the board you have is APM 2.6, this is normal.

I tried with a different computer and works, all flight modes are normal now in the second computer… so it seems that the problem is related to the computer. I tried to uninstall and install MP but problem remains.

Try setting the mode in the full parameter list instead. If you do, don’t use the MP initial setup to change/write any modes otherwise this will overwrite what you did in the full parameters list! Also maybe try Ctrl-f on MP and then regen param.