APM 3.2 loses control and crashes in Loiter, Alt Hold

While I have seen others report similar issues, I have not seen a mention of a specific symptom that I am experiencing. In the several instances where the quad takes off in a random direction and crashed, I’ve noticed that when I try to recover, Simple Mode is no longer working, and sometimes my controls are the reverse of what I expect.

In all cases except today’s crash, I have been able to power-cycle the quad and restore Simple Mode. Today I can’t restore the Simple Mode setting. I’ve tried everything I can think of, short of reflashing the Pixhawk.

While not a show-stopper, Simple Mode has been a big help as I familiarize myself with the Pixhawk and in the tuning process.

Any thoughts?

@Chris Hardwick,
Please provide tlogs and/or dataflash logs to help troubleshoot your issue.

Right. Sorry. I should have anticipated that.

I’ll dig through the most recent logs to see if I can find the offending instance. If I’m unable to locate it, I may have wait until the next crash to be able to provide that info.

Thank you.

Happy Holidays!

OK. Thank you for your patience. I’m currently recovering from surgery and I’m having a rough time. I’m also pretty doped up, so if I don’t make much sense, let me know and I’ll try again. :slight_smile:

I think that I have identified two logs from last Sunday’s flights that indicate crash events. I found a tutorial on viewing the logs and took some time to see what I could learn. I understand hardware, IMUs, the basics of control theory, and GPS so much of it makes sense. However I don’t know enough to identify a fault in this system.

The approximate time stamps for the events that I noticed are:
log 10-38-48 ~ 57000
log 10-58-42 ~ 17700

I did notice what seems to be a lot of z-axis vibration. I’m not sure of the scale of the graph. It just looks like high amplitude compared to the other axes. I have read recently that APM is particularly sensitive to vibe, so I would be interested in some expert opinion on this as well.

Thanks again for your help.


To keep this investigation moving, I have continued to read and to fly when I can. The weather and my schedule do not often have overlapping gaps. However I did get to fly a little yesterday. The purpose was to verify my remedies for vibration and barometer aerodynamic effects.

I had assumed that my DJI screw-on props were balanced well enough from the factory, as they advertise. Not so, apparently. I balanced the props and found a couple to be way off. Yesterday’s data log shows a significant reduction in x and z-axis vibration. If there is still a problem, I got some Moon Gel. We’ll see. The Pixhawk is already mounted with the foam pads that were provided with it.

The barometer test result was less than desirable. Still more work to do here.

The real gem from the day was a better understanding of the control swizzle that happens in-flight. This time I made no assumptions about simple mode and vehicle orientation. I just keep it pointed in the same direction most of the flight, so as to minimize the number of variables. I found that twice, a short time after switching flight modes back to Stabilize from Loiter or Alt Hold, that my stick controls would rotate 90 deg. That is, pitch and roll would switch places on my right stick and would each be reversed. In both instances, I was able to land, disarm, rearm, and take off again with restored controls.

I am hoping to fly again today, to verify my latest barometer mod and to see if I can replicate the control swizzle with Simple Mode disabled in all flight modes. I’ll report what I find.

Thanks to all who have looked into this issue and the attached logs. I appreciate your time.

BTW - I’d like to upload the dataflash log from yesterday’s flight, but even when zipped, it’s way too large. How is this normally handled?



Again, an interesting result. Again, logs that are too big to attach.

This time, with Simple Mode OFF the aircraft flew as though it was ON. It’s like the sense of that variable has been reversed. Didn’t notice my controls getting screwed up though.

In other news, the barometer aerodynamic test was more successful. I saw a much lower rate of post-run altitude loss.

If anyone has a suggestion for uploading or sharing large log files, please let me know.

I was able to fly again today, and I have a little more info to add to this conversation. In today’s flight I found that APM is stuck in Simple Mode while I have Simple disabled in all flight modes. This seems to be true in Alt Hold and Stabilize. Maybe other modes too, but I haven’t finished my radio configuration and only have a two-position switch available for mode-switching.

The other issue, the flight stack or IMU forgetting it’s orientation, remains. Today it was worse than ever. Within a minute of take-off, the pitch/roll orientation would randomly shift by 45 deg to 90 deg. Pitch forward would suddenly become roll right, or something in between. Is this an issue that can be caused by excessive vibration? After balancing my previous set of props, I saw my z-axis vibe drop considerably. Then I lost control again and tried to prune a tree. I installed all new props, balanced to within a hair on a gnat’s bum, and my z-axis vibe is huge again.

Again, my log is too large, at 6MB to upload, even zipped. If anyone can point me toward some specific parameters that would be useful to look at, I certainly will and report what I find.

I’m starting to get kinda frustrated with this. If anyone has any knowledge or experience that could help me get this straightened out, I would be really grateful. I bought a simple, canned airframe and power system so that I could quickly get up and running, and then move on to the stuff I really want to play with. It’s been over a year now, and I’m not past stage 1.

you need to provide logs, otherwise nobody can really know what’s going on.
you can even use services as Dropbox, sure, there is no privacy there, but if you use it for the log only, and don’t install any sync app, it’s safe.

Thank you. I’ll check out Dropbox and get yesterday’s log uploaded.

Dropbox account created. Latest log uploaded.

dropbox.com/s/nzo3ds50w2pfi … 4.zip?dl=0

Thanks again to all who have taken time to read and think about this issue!


disable SUPER_SIMPLE (set to 0)
you need to learn to fly, in stabilize, with no such assistance until the UAV is known as reliable.

The reason is that your log have lots of events, glitches,warnings , until your GPS fix is great, magnetometer(s) are well tuned and work fine, you cannot be assisted by a feature that fully depends on calculating the UAV’s position in relation to you, to compensate for which way you consider “forward”.

Thank you for the reply, Andre, and for looking at the log.

I was under the impression that Super Simple IS disabled when I have that and Simple Mode disabled in all flight modes, when configuring in APMPlanner2. In fact, Super Simple check boxes aren’t even showing up as an option in APMPlanner now; as if it IS set to FALSE already. Are you saying that I need to go into the full parameter list and disable there too? Easy enough to do, but I though that enabling that parameter only made the option available, rather than forcing it to TRUE.

I really thought that I was fly without the aid of Simple Mode. I have also been through the calibration process several times, as I have questioned the calibration myself.

It is true that I did not fly with the aid of GCS yesterday, as time was extremely limited. If there were glitches I may not have noticed. However the behavior doesn’t seem to be different when I take time to make sure everything (that I can identify) is correct, and fly in other locations.

Anyway, I feel this is getting somewhere. Thank you. It looks like there are some things I need to learn.

To start with, while I haven’t disabled any of the pre-arm fail-safes or other warning notifications, are there additional items that I should check?

How can I identify problem-inducing glitches in logs? I have no frame of reference for normal; only my own logs.

How will I know, other than the GCS warning, if my sensor calibration is poor?

If my issues are entirely due to my own elevated cranial density, I can accept that. I still appreciate all of the effort to help me find root cause. I genuinely want to learn about the flight control system and autopilot, in part so that I can operate without needing to lean on the community. So anything that can be shared to aid in that helps us all.

I thank you again, sincerely.


it’s quite possible SUPER_SIMPLE is disabled when simple mode is disabled, I did not take the time to check with the source code.
however: your problem description (stick movement direction changes during flight) fits that perfectly.
The truth is that I never actually used simple-modes, tried it for a few minutes years ago, it did not gave me anything, so I did not play with it again.

glitches should not be a big deal , nor did I see any very serious glitches.
make sure it flies fine in stabilize, then make sure Loiter/Pos hold forks at speed in any direction, the most typical problem may be magnetometer calibration, and that will be revealed by imprecise stops/toilet bowling.

also read about vibrations and make sure it’s within limits.

Good luck.

Hi all,

I also had the same problem. But mine when I swtich from Manual to Alt Hold and raise it to almost full throttle (slowly up to 20 feet) the quad seems to loose power on the left side and almost doing a flip until it crashes. Done some heavy damage (snapped) on both the upper and lower right side of the frame.

I tried to revive it after the crash and resoldered a loose capacitor. The problem is I soldered it in reversed polarity and it puffed smoke once I connect the battery. So I bought a new one same specs ( 470uf 16V).

The problem is when I plug the battery there is only a beeping sound and no led lights flashing same as in this video [youtube]https://www.youtube.com/watch?v=9nsxQk8TY1U[/youtube].

I reinstalled the 3.2 firmware (don’t have the logs anymore), calibrated everything. works fine in MP done but as soon as I disconnect the usb cable to PC led lights disappears and again the beeping sound. It only works when the usb cable is connected. I can only provide the parameters saved but no logs in case you ask. Thanks!


Thank you for the advice. I’ll look into Super Simple and make sure that it is off. I’ll also re-calibrate the sensors.


If feel your pain. If you’ve read this thread, then you must know that I’m a total noob. I spend 40-50 hours a week in computer hardware design, but have little experience with drones. So take my advice with that in mind.

The Pixhawk has two microcontrollers in it, one for I/O tasks and one for higher-level tasks. Based on what you describe, it sounds like the battery-sourced power supply to the autopilot micro is toasted. When you connect it via USB, I think the micro uses a different power supply. That would explain why it works when connected via USB. I’d have to check the schematic again to be sure. I’d replace the whole unit and then make sure the you have your ESCs calibrated before you fly.

dehnermdeleon - the climb in AltHold is a classic result of (very) high vibrations.

THanks Chris and Andre for the swift reply. I’m still checking this quad since I found some loose solders along the way (copper roll) I think it’s what make it bind/arm. Anyway if the LED still doesn’t work another guy told me to replace the whole Flight controller :frowning:

By the way here is my problem on video. Anyway to check the LED circuitry or the FC to see if it’s really fried?


I have been able to fly on two occasions in the last few days. Here’s what I’ve found:

I disabled Super Simple in the Full Parameter list and the copter now flies as expected (directionally) in Stabilize Mode, and doesn’t seem to randomly change control orientation. This is odd to me. I was under the impression that enabling the Super Simple Parameter did not in itself enable the function, but instead makes it available in GCS as an option. That is certainly the way that it worked for me, at first. There were no check boxes for Super Simple in the Flight Modes tab until I enabled the parameter. Then when I was trying to disable Simple Mode by clearing the check boxes and repeatedly writing the parameters, the row of Super Simple check boxes disappeared. I’m not sure exactly when, but they haven’t been available as options for some time. Still the aircraft was flying in that mode until I disabled the parameter. Bug? I dunno, but it sure gave me fits. I hope that takes care of that issue. Time will tell. Thanks Andre, for that suggestion!

Regarding prop/motor vibration. I have balanced my props to the very limit of the technology available to me. Today the log showed my z-axis vibe to be the worse than ever, with Clip0 and Clip1 reaching 105 before the end of the flight. I’m really at my wit’s end with this. My Pixhawk is mounted as recommended with the foam that came with it. My props are balanced until they show zero preference for any orientation. I have a vibration damping mount on the way. If that doesn’t work, I don’t know what to do.

On GPS and compass glitches - I’ve been paying a great deal of attention to GPS fix, HDOP, and warning messages lately. I’ve found that my GPS lock is consistently poor, and looking back, probably has been much of the time. HDOP varies between .83 and 1.1-ish, which I understand is acceptable. However, GPS fix is normally around 4.00. This is consistent at all of the fields where I fly. Occasionally, most often when it first gets a fix, I’ll get a 3.00, but then it drops back to 4. I don’t think that there are any parameters that I can play with here, are there? It either works or it doesn’t?

I’m also getting pre-arm errors. Today it was GPS Speed Error 3.7, and Mag Yaw Error x=2.0 y=0.1. I don’t know how many times I’ve re-calibrated the sensors, using the calibration procedures in the wiki. Many. I hope the flash runs wear-leveling algorithms. I’m not sure where to go from here on this issue either. My setup is pretty unremarkable. I’m not able to identify anything that I’m doing incorrectly or have set up incorrectly.

Here’s link to today’s log. dropbox.com/s/41qd14miixe6r … 4.zip?dl=0

Any thoughts on these latest findings?

You have my sincere appreciation, as always.

Hey folks,

It looks like the GPS and mag errors are my only remaining issues. I’m certain that I am not the only person to encounter the issues described above. If I can get these resolved I can let this thread disappear, or close it, or whatever happens to old discussion threads.

Any idea why my compass calibration and GPS fix would be consistent problems? Instinct says the 3DR GPS/compass has not failed, but that something else is up.

Again, any help is appreciated.