APM 2.8 GPS Module blinking


I am working with an APM 2.8 with a GPS module with compass. I have had a lot of problems with the GPS module.

The external compass refused to show up in mission planner calibration tab. Tried connecting it to I2C and then the smaller GPS 4 pin port. (The compass lead has only 2 wires with 4 more for GPS). Nothing worked.

Then I disconnected the compass from my APM so the APM only uses its internal compass and moved on the GPS. There are two lights on the module, one green and the other blue. They are blinking simultaneously in a weird pattern. First both LEDs blink together in a span on 2 seconds twice. Then the green led just meekly blinks and then both turn off for about 5 seconds.
The mission planner just shows no GPS on the HUD.

Kindly tell me what the problem is. Is the GPS module recoverable or should i just give up on it.


please upgrade your APM hardware to an STM32/Linux one. The APM 2.x firmware is very old and has not changed for many years. It does not support the new sensors that were not available back when that old hardware was active.

How are you powering the APM?
What else have you got plugged into it?
The green is usually on constantly, the blue flashes when it has a lock.
What make is the APM and GPS?
Some details on the hardware will help.
Are you sure you have them plugged in correctly as some have the GPS/Compass connections swapped or changed from the original 3DR versions of APM2.6

I did upgrade my APM firmware a couple of times but to no avail. The GPS sensor is the one that came with the same APM.

I was first powering it from a Raspberry Pi by USB. I thought it might be a power issue so i tried powering it directly with my laptop. Then I also tried a Lipo battery (3s 5200mAh) with the power module.
There is no specific make of the GPS (like 3DR or something) if that is what you mean. If you mean the internals, then it uses a Ublox 7N.
I am pretty sure I plugged in the cables in the correct port. I tried the GPS as well as the I2C port (for compass) next to the Power port. But at least the power LED should have been stable. I did check the power coming from the APM and that all seemed fine.
Don’t really know about any connections being swapped. I guess I’ll have to open the GPS module to find out.

What firmware are you currently running?
It should be 3.2.1
Mission Planner should see the APM and only load that firmware.

Yes the firmware version is 3.2.1.
It said it was the latest update for the device