APM 2.8 Firmware Download for Windows 11

Hello, before anything else, I would like to say I am new to ArduPilot and Arduino in general.
I have tried connecting my APM 2.8 to my laptop through USB. There is no port that is assigned to it on it. Many forums and discussion threads say that it is a Windows 11 problem because the APM is outdated and doesn’t match well with the Windows 11 updates.
I would also like to know if there is any driver to be installed because my APM is new.
All I am able to download is an APM 3.2.1 .hex file.

APM 2.8 hardware is more than 10 years old.
The newest software available for that board IS ArduCopter 3.2.1.
To operate it you need to install and use a mission Planner version from the year 2015.

Almost no one is using that board anymore. And the ones that do, usualy do not help anyone else.

1 Like

Thank you so much.
I did try installing ArduCopter 3.2.1 through MissionPlanner but my laptop refuses to recognise my APM.

You need to uninstall mission planner and install the version described above. Have you done that?

Yupp I have, I re-installed Mission Planner 1.3.30 and it was not booting up

I also want to re-iterate that it is not even getting assigned a port in my device managers,
I went ahead with add hardware legacy and did not understand what to do after that.

As Lucas mentioned, there are still some out there who happen to have that outdated board lying around.
…I happen to be one them.

The problem you are having relates to the fact that there was never a driver made for that board that is suitable for Windows 10 or 11.
Already a year or two after support stopped -still in the days of Windows7 - there was a problem in regards to suitable driver. The reason was Microsoft updated their security certificates and hardware manufacturers had to update their drivers as well. But because there was no one updating the driver anymore it was difficult to be recognised in a Windows7 system which had latest security fixes applied.
I’ve managed to track down a driver which still worked on the later versions of Windows7 but that is of no use in Windows10 or 11.
The only two ways I can think of connecting it is:

  • Using a virtual Windows 7 or XP and connecting it to that
  • Using a flavour of Linux as it doesn’t require any driver.

Thank you Karl. I will try this out on Linux and come back to you on this to let you know if it worked.

It has been a few years that I’ve connected the old APM board.
Just tried and found the following when using Linux (in my case Kubuntu):

  • Using MP 1.3.80 with Mono installed → Select port “dev/tty/ACM0” baudrate: “115200” it connects perfectly. (Your port number may be different. - Auto function causes crash/freeze)
  • Using MP 1.3.70 with Wine installed → Select port “Auto” and within seconds it connects perfectly
    Whichever way you decide to go you’ll need either Mono (full package) or Wine to make it work on Linux.

Whilst this allows you to get operational data from the APM board I’m not sure how you would go with uploading firmware.

1 Like

I have got the APM to connect to the computer, turns out it was a cable issue, however as you said, uploading the firmware is creating issues for me on MP 1.3.68. I will now try Linux through Wine.

I had another idea:
Rather than installing Wine on Linux in order to get MP working, why not download the old APM Planner? This was still active at the time when the APM board was used and you can get a version that runs straight on Linux. (appimage file type) - Provided you use Ubuntu or a flavour directly linked to Ubuntu. (KUbuntu if you like Windows7 style, but others are also avilable)

In that way you can avoid having to download, install and configure Wine.

Just download and execute this file after you got Ubuntu or similar up and running:

1 Like

Hello, thanks for helping me out.
I tried different versions of MP for different things. For example, I uploaded firmware through MP 1.6.8 but calibrated everything through MP 1.6.45.
Now my motor test is failing.
I have an FS-CT6B Transmitter and it is not arming either. I calibrated my ESC’s.
When I go for motor test, it says “Command denied from autopilot” and this is on both versions of MP I mentioned earlier.
Many people are saying I might just try to use other versions of MP or the Transmitter is a problem.
Someone even mentioned that the throttle should not go above 1100 ms but I suppose that is too low.
Just wanted to try everything out before I try everything you mentioned on Linux.

Update -
I disabled all pre-arm checks and went ahead, it is now working fine.

Good to hear it’s working
The reason why the motor test failed is that it wasn’t supported on the APM in the way MP is working in the later versions. - As we’ve been saying: “Hasn’t been supported in many years”
Chances are you will encounter other things that are in theory available with Ardupilot and MP but are not compatible with the APM board.
I would at least stick with just one version of MP. Messing around with different versions can cause also problems due to parameters changing in different versions.
The 1.3.70 version should still be useful and is also able to run on Wine in Linux if required.
But I would suggest looking at the APM planner as it is also available for Windows and is essentially a more basic version of MP. - As such more suitable to the APM compared to more recent versions of MP.

Good Luck and happy flying

1 Like

I dusted off the APM craft and tried Motor Test via telemetry (USB port long gone) and it worked with the latest Beta version of Mission Planner.

But, get a new Flight Controller.

1 Like

You’re right Dave, does in fact work. - Got curious after your remark.
Tried standard MP with USB cable on Linux - motor test working after increase of throttle %.
Also was surprised how quickly the old 3DR GPS got a lock - Indoors! …cool

Then tried APM Planner as it runs straight on Linux as well as on Windows.
All the regular functions worked. But doesn’t appear to have motor test function, so couldn’t test. (also using USB cable)

And yes, I second that " Get a new flight controller"

1 Like

Karl, thank you for being of so much help. I have learnt a lot and now, thanks to you, have a deeper understanding and can experiment on the APM board with APM Planner as well as Wine on Linux, that is what I will do today.
The reason I am not getting a new Flight Controller is, I am on a budget, the same reason why I am still using the FS-CT6B Tx, before this I was learning on the KK Flight Controller, so things are really tight for me.
Lucas and Dave, thank you guys too for the help.
I’ll go ahead and tinker more now.

Yea Karl is does work but you may have noticed that it doesn’t give full messages in the messages screen. It only says “initializing APM”. Better than nothing though!

Mission planner 1.3.34 was released in 2015; currently, it works well with APM 2.8 https://firmware.ardupilot.org/Tools/MissionPlanner/archive/MissionPlanner-1.3.34.msi

Hey, i have the same issue. Can you tell me how you fixed it.