Servers by jDrones

Apm 2.8 compass calibration error 99

(John L Walchester) #1

I have just starting setting up kit apm 2.8 with 6M GPS with Compass L5883 . when calibrating the compass no points show and it shows error 99

2 Likes
(John L Walchester) #2

My bad put the cable in the I2C socket not the one below the GPS socket.

(David Barnholtz) #3

I have the same thing, how do you fix it ? I have a apm 2.8 with a JMT GPS / compass 6M ,the 4 pin plug is in the 12c & gps 5 pin in the GPS

(Iwan Roberts) #4

Good evening All

Just bought a kit and getting the same error when calibrating the compass no points show and it shows error 99.

Help please

thanks

(David Barnholtz) #5

if you have a 2.8 with external compass do not use the 12c, plug it into the plug under the GPS plug and you have to remove the jumper to the right of the GPS

(Ahobby) #6

A common issue with the GPS/Compass not talking to your APM 2.8 board is often due to the jumpers not being soldered on the back of the board to enable the I2C port. If you look at the bottom of the board you will see a selection of jumpers. You will need to solder a connection on the MUX_SCL and MUX_SDA jumpers as shown below:

The reason for this is doe to one of the added features with the APM2.8 allowing you to customize what the I2C power it used for, as it can be used as another telemetry port for OSD instead of compass etc…

(Reff) #7

Thank you Daveb, that worked for me !

(Isaacgarner02) #8

Can you post pictures of the front and back of your board? I made the conections but the compass calibration still dont show data points or anything like that, and gives me error code 99…

(ROZHAN E TAMMUR) #9

hi sir i am using apm 2.8 without gps but it is showing the 1 . 99 error in compass calibration and i am not using any external kit compass,