APM 2.8 arming issues


Here is the problem, I´m able to arm the motors but when I give ANY throttle, it goes to something close to 50%, is not linear, is like binary (ON / OFF).
It´s very weird, because when I do the ESC calibration once I move throttle down I´m able to control the throttle as expected, so it´s not a radio or wiring issue.

Have you seen something similar ?

Here is a video of the problem:
I´m putting something between 5 and 100% of throttle on this video.

Thanks in advance

Please post a log file from the FC.

What mode are you in?
What version of FW are you running?
Other details?

Most can be gleaned form the flight log.

1 Like


  • FW is 3.2.1 (latest available for this board).
  • The mode can be AltHold, Stabilize or Auto, it doesn´t change the behavior.
  • Other than that, all I have is the video posted earlier :frowning:

The FC log converted to TXT is here: https://www.dropbox.com/s/co5fjm1rxgn0yem/flight_log%20sample.log?dl=0

Please let me know if it helps


And here is the binary log: https://www.dropbox.com/s/bkcc7fxm4w24s1q/2017-05-28%2021-43-58.bin?dl=0
To be honest I don´t see much here, no errors. it´s very weird.

Thanks !


So - i’m quite new myself, but have a similar frame and APM2.8 as well and hopefully by helping others, i can learn something too!

Few things i see in your log:

  • You seem to provide nearly full throttle if i look at the RC3 input.-> Is your radio endpoints setup correctly?
  • Your log currently doesn’t have RCOUT, which can be useful to see what is send to the ESC’s.
  • Did you calibrate the ESC’s?
  • In the log, it seems to be in AltHold mode only. Are you sure the mode-setup has been done correctly?

Hi Ruben,

Thanks for your feedback here.

  • Now I’m not doing full throttle, in fact doesn’t matter how much throttle I give, it always spin on the same speed, like I mentioned is a “binary/digital behavior”
  • I don’t know what the RCOUT is or how can I set it. Any idea ?
  • ESCs are calibrated, and like I said, once I finish the calibration reducing the throttle to the minimum, then motors work as expected, if I remove the battery and plug it back, is again behaving on this way.


Hi Fernando,

The reason i say you’re doing quite high throttle is this graph:

If i check your parameters, then RC3_IN is 1087 and your RC3_MAX is 1922. This is normal and the same for mine. It means that around 1500 is 50% throttle. Most of the peaks in the graph are about 1500.

RCOUT is something i have in my logs. Maybe you can configure your APM to log everything (temporarily). RCOUT would show the output to your ESC and might explain why they are spinning up so high.

I’ve got very little knowledge of ESCs, but maybe there is some incompatibility between ESC and APM2.8?

1 Like

You are in an altitude hold mode so the FC is trying to spin up the motors to get to the desired altitude.

Try testing it in Stabilise mode or Acro.
In Stab you can test the motors by having them at low throttle and moving the quad in each axis.

Stab should be your base test mode.
Have you calibrated the radio?
Channel 5 seems to be either noisy or uncalibrated.

Have a look at your Dalt to alt.
It’s just trying to climb to bring them in line.

So testing in any auto mode is not a great idea

I´m using channel 5 to move across the flight modes just as a test.

I tested it again using both ACRO and Stabilize and is exactly the same. Motors ARM, but regardless how much throttle I give, it goes to the same RPM no proportional.

Have a look on this video I just did: https://www.youtube.com/watch?v=8kxl00jSJ_0

You can clearly see the problem described.


Also have a look on this other flight log, this is about the video I just did

This is so weird …

Can you increase your logging level [please.

At the moment all you have are the bare basics:

Have a look here as @cyclops earlier.

Hi Mike, is the parameter LOG_BITMASK responsible for the log level ?
What value would you recommend to put there ?
If this is the value, here are the options I see:
830:Default 894:Default+RCIN 958:Default+IMU 1854:Default+Motors -6146:NearlyAll-AC315 45054:NearlyAll 131071:All+FastATT 262142:All+MotBatt 393214:All+FastIMU 397310:All+FastIMU+PID 655358:All+FullIMU 0:Disabled


Just add all logging. Since you’re still on the bench, it doesn’t matter that the APM is a bit busy with logging.
In the last log you posted, it seems you’re correctly in stabilize mode.

I’ll work on this this evening !
Many thanks !

Ok, now I think the log is FULL:

Please have a look and check the video, is exactly what is happening, note that I´m giving very low throttle and motors are not increasing RPM on a linear way, the video clearly demonstrate the problem.


  • Radio is properly calibrated.
  • If I do the ESC calibration then motors work exactly as they were supposed to do, but they it stops working and reverts to the problem once I disconnect the battery and plug it back.

If the log is not yet full, please let me know, I´m quite new on APM board so I not very familiar, but the log bitmap is set to 655358.


Only for a short period of time at the end of the “flight” I give full throttle.

As you can see regardless how much throttle I give in the controller the motors are going to about 1500, I used throttle 5 times in this log, most times below 1200, and only the last time full (1900/2000) and it doesn´t change the fact that motors are going to the about 1500.


RC OUT Channel 3 is the output to motor no: 3’s ESC. ie ch 1= motor 1,ch 2= motor 2, etc.

Thanks, but anyway you can see the problem.
Here or the 4 motors + CH3 Input (throttle)

I’m not an expert. But in the above log is this trying to fly or is it sitting without the props.
Have you calibrated the ESC one by one ?

Yes I did
All at once and one by one, there is absolutely no change
The quad is on the bench without props

So - again, only guessing :slight_smile:

If i look at your output, it seems that one motor is NOT spinning up while the others are spinning more. It looks like the drone is trying to correct some inbalance.

Have you done the compass calibration?

Are you sure the drone is level?