APM 2.6 with ver 3.3 arduplane mode help!

Hi new to APM 2.6 with ardu plane

downloaded latest MPlanner, and uploaded arduplane 3.3 firmware to board. board working etc however -I only have modes Qstabilize, Qloiter etc no other type of mode I have tried to change and load/write parameters but always has Q modes only options?

Is this board related

Are you sure you have the right firmware loaded?

Apm 2.5/6/7/8/9 boards only support up to ver3.4 but the quad plane feature’s weren’t introduced until ver3.5

Hi Mark

I have uploaded earlier versions of arduplane than 3.4, should I try a factory reset first before I try again.



I have now solved this by downloading an early 2015 version of the MP software. Correct modes now available for arduplane firmware 3.0 thks.
When looking for info on this problem it was always advised to download the Latest ver of mission planner then upload a compatible firmware ver of Arduplane for the 2.6 board. However the answer seems to be load a 2015 release ver of Mission planner then an earlier ver of the arduplane firmware . Does this make sense?