Apm 2.6 unable to calibrate compass v 3.2.1

Hi all I have so far managed to set up my arducopter the only problem I have is calibration compass on basic set up.
At the moment I am using a tethered connection to my usb mac but I am sure I have managed to turn on all axis as directed but keep getting error after rotating for 60 seconds.
I tried calibration of my iphone compass in same area with no problems…
so is there any diagnostics I can run to test external compass gps module v2.0…
any help would be welcome

Hi ,

Do you have a red led in the GPS + Compass unit? This indicates the GPS has power and the compass has power.

Please make sure you have this connection:
copter.ardupilot.com/wiki/common … _to_APM_26

Also enable the compass, auto dec detection and select the APM with 3DR GPS/Compass:
copter.ardupilot.com/wiki/common … _to_APM_26

Try this procedure outdoors:

Also you can test the compass in terminal, by test, compass.

This helped me on my Pixhawk. It would happen after compassmot calibration…


My unit has a green led which lights up to indicate power. To gps/mag its the v2 version.
I tried the apm with gps/meg disconnected system reports voice alert mag failure once reconnected and re booted error goes away.
I will try outdoors on my external 433mhz link kit when it arrives…