APM 2.6 timing out with APM Planner 2.0.0 (RC3)

Hi all,

I recently bought an APM 2.6 and I’m trying to do the initial setup for the first time with the APM Planner with no luck.

I’m running APM Planner v2.0.0 (RCE) in a osx environment and following this guide: http://planner.ardupilot.com/wiki/common-load-firmware-apm/

I’ve connected the APM to the computer with the usb and connected the APM to Mission Planner (the baud rate is at 115200 and I don’t have an option to select Arduino Mega 2560 as its described in the guide but I can select the usb port which my APM is connected to).

Later on I’m just selecting the firmware, I can see in this screen that is detecting my APM, as I read Arduino Mega 2560. When I select the copter firmware its says Downloading (I can see a blue led blinking in the APM) and then I get a popup saying It couldn’t load the firmware to the APM.

I keep getting this time out message in the logs:

avrdude: stk500v2_ReceiveMessage(): timeout :open_mouth:

And then the APM Planner crashes and I need to reboot the computer.

I’ve tried a different usb port, and I’ve installed the latest v I could find of APM Planner for mac but still no luck.

Any ideas?

I’m going to install a virtual box to install windows and download APM Planner for windows to see if I have more luck… Would be nice to figure out why I’m getting this error… :cry:

I suggest that you try and program your APM with MP as APM Planner 2.0 still has some growing pains.
You probably have a serial driver issue.

In the .dmg for mac the Installation Instructions explain you need to install the crosspack-avr package to install to APM2.6. Did you do this?

I also want to know why you are having issues (I’m helping with the development of APM Planner 2.0), so I look forward to more details on this?

There’s also a log.txt file generated in your $HOME/apmplanner2/ directory. If you can attempt flashing and upload here, that would be great.

[PS: we can move this post to the APM Planner 2.0 forum if you think that’s the proper place?]


Thanks for the quick response! I’ll give it a go :wink:



I’ve uninstalled and reinstalled everything again just in case (following the installation instructions for mac) and I still get the same error.

This is what I get in the log.txt when trying to flash and upload: http://pastie.org/8691055

About moving the post, sure! I guess that the APM Planner 2.0 forum makes more sense.




I gave up with APM Planner in Mac because I couldn’t get it working… Now I’m trying it in in windows using virtualbox and It seems to do the upload ok but it fails in the verification. :S I tried with different ports but same issue…

This is the log: pastebin.com/fCbYpB7y

This would seem to be a hardware issue. As the checksum is failing. The board may be broken.

Wow you almost killed me! Finally got it working so the hardware is ok. :smiley:

I gave up using VirtualBox and installed Win 7 ( :blush: ) in an old laptop and installed the firmware successfully using both mission planner and APM Planner 2.0.0. (I was able to connect the ardupilot in both)

However now, I would like to use APM Planner 2.0.0 in my Mac but if I click connect nothing happens :neutral_face: I followed the installation instructions and still no luck. In the list of ports I don’t see any port with my ardupilot (I do see this in windows).

Any idea of what could be wrong @billboney?

Thanks in advance.

I’ve just updated APM Planner from RC3 to RC5 and I’m able to connect the APM. :stuck_out_tongue:

Awesome :smiley: