APM 2.6 tilts right. Three controllers with the same issue!

Hi everybody,
I am new here since I have an issue with an APM 2.6 and Arducopter 3.2.1. I have three APM2.6 that show all the same problem as follows:

  • Copter perfectly levelled according to artificial horizon, RC calibrated, voltage > 11V
  • RC channels remapped, 1=Throttle, 2=Roll, 3=Pitch, 4=Yaw --> works as it’s supposed to be
  • No compass (but problems also there with compass)
  • if powered up, armed and throttle up the copter tilts to the right side (all three boards in the same angle), Mot 2+3 runs far higher
  • if the copter levelled by hand, the right side motors (1 + 4) almost stop while 2 + 3 run with high revs
  • if copter tilted to the right side by hand 1 + 4 accelerate
  • parameters (chXout) show 1162 on all motors in idle
  • with full throttle and copter kept levelled, motors chXout show right handside motors are lower although copter is levelled!
  • I changed the ESCs from left to right, the problem remained the same
    I had all the three APM 2.6 working well with previous firmware versions and one of it even with 3.2.1.
    I’m currently downloading a log file, the size is very large, I hope I can upload it here later.
    Please see the attached images of the horizon and the parameter status at full throttle (ch1in).
    I don’t know what could have happened and what ist the reason but it’s driving me nuts. Please help,
    thanks in advance!

Please provide tlogs and/or dataflash logs to help troubleshoot your issue.

Had exactly the same issue when I upgraded a friends tri-copter from 3.2 to 3.2.1
No other changes and many calibrations later it still did it. Dropped back to 3.2 and it was fine again.
He wasn’t to bothered so we just left it on 3.2

Hi MarkM,
good to hear you could solve it! I cleared the EEProm and stepped back to 3.2 several times but the problem is still the same. I assumed it would be a hardware defect first, but after instaling 3.2.1 on two other APM2.6 the problem appeared there as well.
Calbrating the accel doesn’t change anything because it is perfectly levelled anyway. For any reason, the motor output is calculated wrong.
I will upload a log as soon as possible. Unfortunately the file size is very huge!

Good evening everybody,
I saved a tlog that shows the strange behaviour of my APM2.6. I went also back to 3.2 but it is same as in 3.2.1. After connecting, I armed and increased the throttle up to full. You can see ch2out and ch3out increase much more than 1 and 4. This causes the tilt to the right side although horizon is levelled. Can anybody understand what happens? Thanks guys for your help! regards, Rob

Good morning, can anybody help?

I just upgraded a friend’s APM mini to AC3.2 and then to AC3.2.1. The same phenomenon also there in both versions.

  • I can’t imagine, it is a hardware fault.
  • It should not be something with my RC since the signals are viewed right in Mission Planner
    There is no offset on the roll channel that could cause a tilt
  • The accel works properly as I can see on the artificial horizon in MP

What else could lead to this problem?
Has anybody analyzed the tlog?

Thanks for your help!

Nobody can help?

Hi everybody,

it happened a few times in the last couple of hours, that after some testing the horizon was not level anymore. It always happened after reconnecting the APM2.6. the misalignment was always same as shown in the screen shot attached. Could this cohere with the wrong calculation of the mot out values?

Hi again,
I’m getting more and more hopeless with my APMs and the QC firmware. I bought a VR Micro Brain in order to be compliant for FW versions > 3.2.1. I was hoping that the issue with the roll offset would resolve then but with QC3.3.3 on the new controller, the same thing happened again.

I changed the RC sender and receiver but this didn’t fix the problem (as I expected since the RC signals are displayed corrrect in Mission Planner). The calibration, of course, was done.
The horizon is also perfectly levelled, so again, I don’t have a clue why the motor outputs 2 and 3 (left motors) are substantially higher than on the right side. Just as with the APMs, the copter tilts right.

I can’t imagine the problem comes from a failure in the controller or the software. I tried three APM2.6, one APM Mini and a VR Micro Brain as well as firmware versions from 3.2 to 3.3.3.

Again, I kindly ask for your advice, I can’t solve the issue on my own.

Thank you!