APM 2.6 tilts on flight

Hello everyone,

I’ve recently (yesterday I mean) built a little 250 racing quad using spare parts I’ve found on amazon, including an APM 2.6 and his GPS/Compass module. I’ve trying since hours to make it fly correctly, but I’ve always the same problem with it. On take-off, it tends to tilt to the left to stabilize itself 30 degreees from the horizontal. I’ve done the calibration a lot of times, reset the apm, changed the firmware, but anything worked. I can limit this tendency by aplying roll to the right side.
This is not a problem of escs, motors or propeler, just a problem of the apm trying to stabilize itself not horizontally (when trying to fly the quad in ESC calibration mode, everything works fine).
I’ve found a way to cheat, by chnging the accelerometer calibration, but the flight is unstable and that’s not a good way to solve this problem. I use a Graupner TX/RX system, using ppm from the rx to the flight controller. Any idea of what’s causing this ??


Please provide tlogs and/or dataflash logs to help troubleshoot your issue.

Here is one of my log files. I don’t know when it has been created on the APM, perhaps isn’t it the good one…

Ive unsuccessfully tried to downgrade the firmware from 3.3 to 3.2.1 on the APM but the problem stays the same… Any idea ?

I had a similar glitch on a friends apm.
With 3.2.1 it would lift off then bank right every time.

Went back to 3.2 and all was well again.

I did it but that doesn’t change anything. Same behavior.

You have run into the RC mapping bug reported with this versions of APM.

To fix this you need to either not use Channel mapping and put the throttle back on channel 3 or
Move the values from RC1MIN/MAX/TRIM to RC3MIN/MAX/TRIM and vise versa.

You see the RC1, RC2, RC3 don’t seem to follow the channel mapping so it tries to use the values from the wrong bucket.


The problem is that I use ppm on my graupner receiver, and I can’t change channels on the receiver. With graupner, channels are mapped like that : ch. 1 : throttle, ch 2: roll, ch 3 : tilt, ch 4: yaw. I need to change that to be understood by the apm

Look at the following link that describes these values.
copter.ardupilot.com/wiki/arduco … parameters

Then use mission planner and write down these values and try and swap them and see if the problem goes away.


Thanks a lot ! This was the solution of my problem ! Now, I can clearly see an other problem… The quad flies, reponds correctly on every axis, but tends to wobble constantly… I don’t think, seeing logs, that it is a vibration problem (logs are joined)… A problem always hide an other one ! I’ll search on my side but if you can give me help… :wink:

Just PID settings, everything is now in order to fly ! Thanks everybody for the support !! :wink: