APM 2.6, Plane 3.2.1 MAVLINK issue

Has anyone run into an issue with the initial set up wizard in the current version of Mission Planner when it loads the firmware (Plane) version 3.2.1? Mine will load and verify fine, then when it tries to communicate via MAVLINK I am getting time outs. The APM 2.6 is working as it will load and successfully calibrate for rover and copter. This only fails when trying to load the plane firmware. I do not see a way to load old firmware as the current version of MP “automagically” retrieves the current version of the firmware, without prompting which version you want it to load.

Any suggestions would be welcome!!! I have tried a different com port, different com settings, and different device drivers. That is when I finally discovered that copter and rover work and pane does not.

I finally found a way to upload previous versions of the plane firmware. I am using MP 1.3.28, and at the bottom of the wizard screen, sure enough, there is a section to load older versions of the firmware.

It loaded, Mavlink worked, but then got to the compass calibration and it shows 3 data points collected and stalls there. I have moved the compass around and it will not collect any additional points. Would this be a external compass issue, or an APM 2.6 issue? Or maybe still related to the earlier Mavlink issues I was experiencing?