APM 2.6 connection to Mission Planner/firmware

Hello, I have just received my APM 2.6 and I was following the instructions on initial setup as per copter.ardupilot.com/. I installed the driver for the usb and it installed fine and shows up as com port 3 in the device manager. ( I am using Windows 8.1 64 bit on both computer and laptop) I downloaded and installed mission planner, set com port 3, and buad of 115200, and then preceded to install firmware as per instructions. On both laptop and PC it errors out while uploading the firmware. I have tried it multiple times on the systems and only once did it actually install the firmware. I tried it again just to make sure it was working but it is back to not connecting to upload the firmware. I have attached a screenshot of the error, I would greatly appreciate any help you could give, as I just spent $500 on this stuff from 3drobotics. Hopefully I am just doing something incorrect and it will not be an issue with the hardware.
Thank you for your time in this matter,
Don Wallace

I figured it out, one just needs to calm down and have a look at whats really happening. The baud rate was correct on the mission planner but the pc in the device manager was running at the wrong baud rate. Went in and manually change baud rate in the device manager and BOOM worked. Hope my stupidity helps others. :smiley: :confused: :smiley: :confused:

How do you change the baud rate on your pc?


To change the baud rate in windows you need to do the following:

Press the “Start” button
Click on "Control Panel"
Click on “Administrator Tools” - note if you don’t see click on the “View by:” pull-down and select "Large Icons"
Click "Computer Management"
Click on “Device Manager” on the left column
Click the little arrow beside “Ports” on the right column to open the list - Almost there! :smiley:
Right-Click on the "Arduino Mega 2560 (COMX) - The number of the X will be the COMmunications port you connected to the Ardupilot within Mission Planner
Click “Properties” from the list
Click the “Port Settings” panel
Click the “Bits per second” pull down
Select the baud-rate you had in the Mission Planner (The number right beside the “Connect” button). This is typically set to 115200
Click "OK"
Close all the windows

See the included screen capture to see the windows you should be seeing…

Unfortunately this did not fix my problem but I hope yours get’s working…


Well: So I am not that lucky, my APM2.6 burned the 3.3V LDO, a very common, I have finally learned, thing to happen on this boards, and it looks to me that it comes from changing the board from one copter to an other, ( different ESCs). I am sorry that I have to learned this way, so if I was told I will not moved from the first one. The board is now useless, will not connect with mission planner, or arm, or nothing. I may put it for its lights on a decorating place.

I had the same problem
to rectify this I changed the flow control to Xon/Xoff in the port settings and it worked
bits per second to 115200

How did you guys come up with the idea of twiddling those values?

What about the other values you can change

And curious why 115200? All the instruction’s i’ve seen have had indicated you should use 57600?

Any input would be great - brand new iris+ out of the box and I’ve spent at least 4 days trying to work out what’s wrong with no luck…