APM 2.5 not throttling up

Hello guys,

I have a friend that build a quad around an APM2.5 board, in the past I had also one and I liked it, but now the firmware has changed and I couldn’t find the option where I selected the motor power (there ware tree options as I remember).

We did radio calibration and everything looks ok in Mission Planer, also did ESC calibration, each ESC at a time while connecting the ESC to port 3 of his receiver. All the esc beeped correctly confirming throttle calibration.

When he tries to take off the throttle is not increasing motor rpm, the motos seemed to remain at idle speed, maybe just a slight variation, when he tries to move the AIL, ELE stick the motors start spinning much faster, and it leans the quad in correct direction, but the motors spin faster only when he moves all the other sticks except throttle. In mission planner if he moves the throttle sticks the green bar increases correctly, from the bottom to the top. The quad also arms correctly.

Don;t know what the problem might be, any help is appreciated.

The quad configuration is

NTM Prop Drive Series 28-26 1100kv
Multicopter SimonK Speed Controller ESC HVSK-40A (OPTO) (he had those from another bigger octocopter)
10"props
4S 6000mah Nanotech lipo
Frame : a copy of DJI Flame Wheel F450

@sibianul,
Please provide tlogs and/or data flash logs to help troubleshoot your issue.
Regards,
TCIII GM

Ok, called my friend now, when he will send the logs I will upload them.

Thank you.

I downloaded the logs from his APM, when trying the option dataflash logs via mavlink I got errors eachtime. Can’t receive log list.

I could download the logs using Terminal and Download logs tab, but there was no data in any of the kml files, don;t know why there is no geo location info in thekml, I zipped more logs files but wanted to give you only the ones that ware generated when the copter was outside, unfortunately I dont know which they are.

but if you can figure out the issue from the attached logs I’ll be glad to help my friend make his quad fly.

Thank you in advance!

hi this sounds like the same problem as me
I have tried redoing the full install and calibrate and still cant get it to work.
I am going to try and redo the receiver next

moosehsu & sibianul I am having the exact same problem and there is absolutely ZERO help from any of the forums I have posted on.
I cant d/l dataflash files either as they state there is an error receiving the log list.

I have used reset button on board, reinstalled firmware and recalibrated ESCs and radios so many times I cannot count them, it always ends the same, no throttle!!
I have had enough, I am frustrated and sick of it

Do either of you find that the motors respond perfectly in the test before battery unplug after an ESC calibration?
and will throttle/motors work perfectly well on an Auto take off or mission?
mine does this but switch to Stabalize or other mode with manual throttle control and will only get just over idle speed - maybe 1/3rd throttle - which will drop out of sky if flying

I think its almost time for this P.O.S APM board to get binned and go back to the simple KK board.

can I at least get some assistance from someone to start completely from fresh with this? maybe reflash or complete reset? or how do I look at the throttle settings

Welcome to the forums Fraser, a stunning way to get folks to help.

For all of you I would start from page one of the wiki and do everything again. Paying particular attention to RC calibration and failsafe settings.

Here’s how to get to the log files

copter.ardupilot.com/wiki/common … etry-logs/

I think i am going to give up on this problem i mite get a pixhalk

Gary. Sorry, Yes I was probably a bit harsh, but like moose I have tried exactly what you suggested many many times with no success and was EXTREMELY frustrated! , and yes my first post on this forum but as was on this thread there was no suggestions of a fix, I will say thank you for your suggestion as it is a start that needs to be worked through and if persisted with probably would have got there in the end, and was more help than many other forums or from other APM users I had talked to

Font give up I just solved mine.
I reset my EEPROM through the terminal tab in mission planner, probably easier to Google it than me explain.
I should have noted my settings before and after to see what the issue was, would be good if someone doing this fix could do that

I cannot get ESC Calibration to work.
Ardupilot 2.6
Either: Firmware 3.1.5 or 3.2.
Either: Hobbywing Quattro ESC or four Exceed Proton ESCs
I have two quads and have flown them both recently with 3.1.5, so I think the hardware probably works. I decided to look at logs yesterday, and learned that logs only work with firmware 3.2 and up (is this really true?) so I loaded 3.2.1. Now I cannot calibrate the ESCs.
I THINK the Calibrate ESC instructions say to “put the throttle up, connect the battery once, disconnect the battery, connect the battery again (supposedly causing all four throttle signals to be fed directly through the APM from the receiver), wait for some tones for 2 seconds, pull the throttle down, wait for a long tone, and you’re done”. When I do this, the ESC does NOT give a long tone, it gives it’s normal-operation song, and the motors will spin up OK with the throttle; however, after unplugging the battery and re plugging it, all I get are single beeps every 2 seconds, meaning “no throttle signals are detected at the ESC”.
I am certain that I am doing something wrong, but I cannot figure out what it is. Anyone got a suggestion?

One other thing: I can clear the EEPROM when using 3.1.5, and that did not solve my problem with calibrating the ESCs. I cannot clear it when using 3.2.1; when I open the CLI I just get a massive code download.
Some extra info: my minimum throttle is 1089, and maximum is 1938…

Guy9495 captured exactly what I am experiencing:
youtu.be/QH9xN9_FyBU

What am I supposed to do now? Any suggestions?

WOW! I think I have found something useful in the search for a solution to the dreaded “no throttle signal” beeps ( the ones that occur every 2 seconds, like in the video posted in the entry above).

Over the last month, I have tried and tried to get one of my quads out of this “no throttle signal” beeping scenario, with no success. During that time, I have saved numerous Full Parameter Lists. Yesterday, I fired up another quad, loaded 3.2.1, did all the calibration stuff per the normal routine, then flew it. No problems.

I then took that working quad back to the computer and loaded various versions of the Full Parameter List (FPL) which were stored during the past month. I found one FPL which causes the “no throttle signal” problem, and one which causes the quad to start normally. Excellent!

Now all I have to do is compare the two FPLs, figure out what parameter causes the “no throttle signal” problem, and releases us all from this nasty problem. It wasn’t that easy. There were about 30 differences between the two lists. Most of them were items which did not sound pertinent—various gains, for instance. However, I did try changing a few of the FPL entries in the “non-working” FPL to the value gleaned from the “works OK” FPL: INS-prod; log bit ask; trim throttle; compass external; circle radius. None of these changes fixed the “no throttle signal” problem.

I bet someone on the development team, or some knowledgeable user on this forum, could look at these two FPLs and tell us all what the magic bullet is. I will be happy to supply the two FPLs to anyone willing to try…

I have found the difference between a working “Full Parameter List” and a non-working FPL. By a process of elimination, I found that just two little parameters can cause my APM to issue the dreaded “throttle signal not good” beeps. The parameters are RC1MIN and RC2MIN, and the bad values are 1321, with the good values 1251.
This is good news for those of us who have had problems getting our APMs to proceed with normal arming, as opposed to giving the “beep-every-two-seconds” signal which indicates bad throttle signals.

But now this answer generates some important questions: What can possibly be the reason for this goofy result? How can the difference between a “good” value and a “bad” value be so small, especially when they both are reasonable values? Why would the software or hardware even look at these values at start-up?

And maybe these are more important questions: is anyone reading this post? This forum? Is there any way to know if my APMs are really a dependable flight controller?

What can possibly be causing the RC1MIN and RC2MIN values to be out of spec? Well, I figured it out—sometime in the past, I used “end point adjust” to dial down the sensitivity of my roll and pitch performance. Wrong answer! I don’t think it says so anywhere in the setup instructions, but you must do your radio calibration without invoking “end point adjust” or “adjustable travel volume” or whatever it’s called on your transmitter.
In fact, in the setup instructions, it clearly says “for channels 1 to 4, the MIN must be less than 1300 and the MAX greater than 1700.” I violated this rule and that’s what caused my difficulty in getting rid of the “beep every two seconds” signal that indicates that the ESC is seeing an “unsatisfactory throttle signal” condition. When these limits are violated, the APM apparently just impedes throttle signals from going through to the ESCs, thereby allowing the ESCs to generate the “beep every two seconds” warning. It’s really very simple, once you know what’s happening!

I hope that I have described this clearly enough that nobody will have to spend 2 months figuring it out, like I did!

Jim,
I just wanted to pass along a thank you for sticking with it and updating this thread with your findings. It will indeed be helpful to someone down the road, no doubt. While I’ve not experienced the problem you had, I’m hoping that should something like that happen to me in the future, I’ll be lucky enough to find the answer from someone like yourself who took the time to share the fix. :slight_smile:

Hi everybody, noob here.

Been having the same problems as everybody here, and after 3 or 4 weeks of reading through the rcgroup posts (at least 1500 pages) and messing about trying everything that’s been suggested I was about ready to rip out the APM and stick a good old KK board in both of the Quanum Novas (1 PNF, the other RTF).
I tried the reset/reboot, but as has been mentioned, all I got was a massive code download. Hair pulling out time, and there’s not a lot left to pull!
Then…I found another thread on this site that was a revelation! Praise be, Halleluja!!!
This is what it said to do:

"Seems switching between versions using the standard “Initial Setup” screen in MP planner is not enough.
You need to erase and reset the APM. (I found this in one of the forums)
You have to erase the eeprom which could still have “some memory” of the old firmware, afterwards.

AFTER updating the firmware you want click on the Terminal Tab (CLI)
Select correct COM Port, make sure BAUD is set to 115200.
Click on the Connect APM tab
At the command line…
Type “setup” press ENTER
Type “reset” press ENTER,
Type “Y” and press ENTER
You should see the response: Reboot APM
Physically press the reset button on the APM board (just hold it down for a sec) It will display “erasing eeprom"
Done
You can press Enter 3 times to stop the screen from scrolling showing all the present parameters if you want.
This process is the “clean” way to change to a new firmware update…or downgrade, if you wish.”

So I did all what I was told to do and… Yes you’ve got it, worked perfectly! Armed,Throttled up, everything it’s supposed to do.
Did the ESC calibration and now all is well in the world (or the back bedroom at least)!

Hope this helps y’all as much as it did me.

Wow “hotrodspike” - you saved the day - well, mine anyway. After about a week of frustration with arming issues and throttle issues, I stumbled across your post and guess what? It worked!!! Everything is correct and there are no longer any more pre-arm messages / issues! Thanks!!!

Now, for the life of me, I can’t figure out why I’d go to Terminal mode and invoke the “Reset” command resulting in an EEPROM erase after uploading the 3.1.5 firmware (3.2.1 just doesn’t seem to work for me). Is there a WIKI on this “Erase EEPROM after uploading firmware to it” process? It just seems illogical to me… Thanks

Your not erasing the firmware, you are resetting it.
Erase does what you think.
When I had mucked up the PID settings or the like that was my way out resetting the parameters to their defaults.

Thanks Mike - I was referring to the:

Physically press the reset button on the APM board (just hold it down for a sec)
It will display “erasing EEPROM” response from the APM following the physical reset button press. It shows “erasing EEPROM” - so is it or isn’t it erasing the EEPROM? If not, then shouldn’t it read “resetting EEPROM”?