APM 2.5-multicopter with 3.2.1 all over the place


I had a small DJI F450 quad with an APM 2.5-kit (3DR APM 2.5, 3DR GPS/Compass uBlox 7, 3DR PM, 3DR Telemetry) and with firmware 3.2.1 (the latest for APM). LiPo between plates, APM on top, GPS on mast, gimbal under. It worked perfect in all flight modes.

I moved the APM-kit over to a DJi F550 and reprogrammed it (ArduPlane then ArduCopter 3.2.1 for hexa). APM between plates, LiPo on top, GPS on mast and gimbal under. It works splendid in Stabilize mode. In Alt Hold and Loiter it starts to throttle irregularly and goes side to side a little all the time (seems it corrects the sudden throttle changes). It sinks slowly until it would hit the ground, it raises a few meters, …

Last time I flew I had 12+ satellites.

It is compass calibrated.

I have had problems with wind disturbing the barometer so I have put “foam” around the APM like walls and that have worked good with all multicopters with APM. Even the sun may disturb the APM, but thats impossible on this one. I have flown the DJI 550 in days where there is no sun or wind att all.

In stabilize mode it uses the gyroscope and the accelerometers.
In altitude hold it uses the same plus the barometer, right?
In Loiter mode it uses the above plus GPS and Compass, right?
Therefore I guess its the barometer that is the first problem.

Pictures of it:
1: http://forum.motorportalen.net/download/file.php?id=12383
2: http://forum.motorportalen.net/download/file.php?id=12381
3: http://forum.motorportalen.net/download/file.php?id=12382

I have moved the telemetry out under an arm, it interferred.
I use Futaba FASST.
All cables are twisted.
I have the same problem without the gimbal and without the rectractables.
And yes, compass-callibration between any changes in hardware.

I have built 10+ multicopters from 450- to 680-sizes with APMs, Pixhawks and they works fine.

The only difference I can come up to is that the things are in different places. !? Its the same material of frame, same motors, same ESCs, same APM-kit, same RC, UBEC, …

Any suggestions what I should do? Is it just interferrence?! What to do i it is?


The INS_GYRO_FILTER and the INS_ACCEL_FILTER higher values. best regards

I will try change them, thanks. But … I do not have any major vibrations, its smooth. Stabilize works perfect, really stable and Stablize uses gyro and accelerometers. So why should I change raise these values? Just wondering. I got the APC 9x4.5" MRP-props instead of the black DJI in the photos. Higher revs and more stable (at least without the gimbal).

Have you set throttle mid? And what escs are you using?

Throttle Mid? No… How do I do that? I have Max-Min-programmed the ESCs using the Futaba-Receiver.

ESCs are EMax 30A BLHeli 2-4S 400Hz.

Rainer, did you mean raising values for INS_GYRO_FILTER and INS_ACCEL_FILTER would get it more tolerant for interference and not vibrations? But again, it should be the same interference when flying perfectly in Stabilize-mode.

Problem percists, havent tried more than confirmed that Stabilize works fine, Alt-Hold jumps up and down erratically and Loiter does exactly the same, but on horisontal position. Is it possible that there is any interference between anything that can mess up the barometer?

Still… Throttle Mid, how do I set that? I dont get what that means.

Could vibrations do anything for the barometer?

Vibrations can do heaps.

But unless you post a .log file from the APM it is impossible to guess what the problem might be.

I cant upload it here (file is 1300k and the limit here is 4500k… logic?).
Here is a link to the log-file from today: https://1drv.ms/u/s!ArRUW2agVpZnhApmQk_6KYAQsmma
I flew few times.
First as is.
Second gimbal off
Third with new compass calibration
Fourth with telemetry-radio moved
Fifth with telemetry off

In the above flights I switched between Stabilize, Alt Hold and Loiter.
Stabilize was always stable.

When I compared CTUN Alt, GPS Alt and Baro Alt with each other, they are very different.

What causes the irregular flight characteristics of my DJI F550 Hexacopter in Alt Hold and Loiter? Stabilize is rock solid.

I also disconnected the gimbal, and the telemetry, and the LEDs… all that wasnt needed for flying. It still jumps around in Loiter and Stabilize Mode. Stabilize rock solid. What to do? I flew well with the DJI FlameWheel F450. I just moved the controller and reloaded it with Hexacopter-firmware (3.2.1).

Your log file has very little information as you are logging very few functions.
There are no Alt or Loiter modes in that log file.
Can you get a more comprehensive log from a flight and post that?

Oh, which functions do you need? I can see now that I dont find the FlightModes. But I think it was in Loiter all the time.
I also see that RCIN C3 (Throttle from radio?) Is all over the place. Or is it the signal from the APM?
CURR ThrOut is also all over the place. And CTUN ThrIn and ThrOut

Between 11-14 satellites, HDOP between 1.3-1.5.

Red is CTUN Alt
Green is GPS RelAlt (same as CTUN Alt)
Blue is GPS Alt (differs a lot)
Neglext the battery error, it wasnt used, arent setup right at that moment.

Its an old multicopter and everything is old on it, but it flew perfectly on a quad and the stubbern half of me wants to find the problem with this setup. :slight_smile:

I took it apart and resolder and moved around the PM, Telemetry, LEDs, UBEC, retractable legs-driver, cables, … to get less interference with the APM.

I have also made the APM more encapsulated in foam. Also changed the foam inside the APM for the barometer.

I have also used alu-tape on the bottom plate (PDB for to get rid of more interferences.

But the biggest problem is that the firmware dont work…
Using 3.1.5 was something to do regarding to many having issues with the barometer using 3.2.1 which seems much more sensitive and I tried that too, but with problems. Cant compass calibrate (My try to find a solution here on the forum: Gets binding error calibrating Compass ).


Hi again. I tried firmware 3.1.5 but that was a lot of old problems with old firmwares. I gave up and used 3.2.1 again. After all my enhancements it is a better multicopter. No sun on the APM. No turbulence reaches the barometer. A lot less interference. Softer pad for APM. Bigger distances between all that can interfere with each other. Propellers and motors balanced. And a lot more. But the problem are still there.

I couldnt find the filter-parameters. How do I configure the barometer to be a little bit more calm instead of its intense sensing it seems to have now. As I guess!? I dont know. Could be something else? It seems wild when flying, like it senses something and corrects it too wildly. The multicopter goes up and down irratically both in alt hold and loiter. Several meters as most. Thats all. Everything else works.

If the log-file dont describe what you want to see, how do I activate values to be logged?

I googled and found that the INS_MPU6K_FILTER-parameter could be changed from 0 to 20 or 42, not more than that. Someone changed it to like 96 and the multicopter flipped. In 3.1.5 it was 0 but that should have been 20 in 3.2.1. If I remembered right. Will test this anyday. If it works, I can sell the multicopter to someone who wants a stable platform.

In 3.2.1 a value of 0 is default and will set the filter to 20. You can enter 20 if you like, it’s the same as 0.

Okay, so it wouldnt change anything and the multicopter still wont fly well in Altitude Hold and Loiter? Scrapyard next? I dont get why this multicopter is so hard to get flying well, since all the hardware worked fine on another multicopter. And have used 3.2.1 on several other multicopters. Have to see if there are any new vibrations. AccX, Y and Z?

Yes, that’s the vibe data you want to look at. The previous log you posted did not include vibe data, change your log bitmask to enable it.

Too late, I didnt know the log wasnt complete, I thought it should be complete, but maybe that was another log in another multicopter… =) Log all, or what it was.

Anyway, I just flew the hexacopter with the INS_MPU6K_FILTER changed to 20 and now it flies as it should! Perfect! Even okay in wind, 6 m/s. It stood there for 6 minutes.

Great you fixed the problem. There have been some that have suggested this is a bug and to be sure set it at 20 as you have. Personally I have not experienced this across many old APM’s (all retired now) but it has been mentioned.