APM 2.5 hangs when connecting to mavlink

Got given an APM 2.5 last week from my mate who has upgraded to 2.6. He’s been flying with it for months in a quad with no problem and saw it flying the day before I got it. When first hooked up to my PC to see all the settings (stand alone not in an aircraft) it connected to mavlink fine and all the telemetry worked. The next day it would not connect and hung on RC7. After resetting and re-flashing still the same. Then flashed with 2.9.1b, it connected but no telemetry. Flashed back to 3.0.1 and the same, hangs on RC7. Tried on a couple laptops and different cables but still hangs.

Has anybody experienced this? If so is it a software or hardware problem?

I have exactly the same problem with the new Ardupilot 2.6 hardware. I flashed ArduCopter 3.0.1 to it and never got past the RC5 or RC7 parameter when connecting to the Mission Planner.

I tried several USB/serial drivers and different USB ports. I also attached all the hardware (power module, compass, GPS, receiver) and powered the APM through the battery before connecting to USB, sadly to no avail.

Since flashing works and the CLI/terminal works, I’m a little confused what the issue is here.

Any help here is highly appreciated. Thanks!

What version of the MP are you using?

I downloaded the MSI installer for MP 1.2.62 mav 1.0 and I am also using the USB driver supplied with this installation (version 5.1.2600.0).


Try posting over at the DIY Drones website. I have searched through the ArduCopter and MP forums there, but cannot see a similar issue as you have.

Thanks for the help. I checked further using the CLI and discovered that there seems to be a problem with the ACC/Gyro as I see the following messages during startup:

3Calibrating barometerQ///+?QC^///+eO3barometer calibration complete4Z3GROUND STARTAFailed to boot MPU6000 5 times Q///+V?Failed to boot MPU6000 5 times Failed to boot MPU6000 5 times QL ///+?Failed to boot MPU6000 5 times Failed to boot MPU6000 5 times 3Initialising APM...qQ ///+?Failed to boot MPU6000 5 times Qs<///+Failed to boot MPU6000 5 times PANIC: failed to boot MPU6000 5 times

Entering test mode and executing any sensor test yields the same message. As I take it from DIYDrones, this most certainly points to a hardware defect. I will contact my dealer for a repair/replacement.

Nice to hear that you were able to isolate the problem. Sorry to hear that it is the gryo/accel IC. :neutral_face:

I think I am having the same issues.
I am just beginning so the curve is still steep.

Any advice is welcome.
Anyone in Boulder is really welcomed.

Can you please describe your APM symptoms.

Thanks Admin.

I have a newly bought stock FPV Quad from Jdrones.

The board is a Arduino Mega 2560
Using the recommended WFLY WFT-09 with the FrSky DFT telemetry and FrSky D8R-ii plus .
Can you clarify which is the receiver and which is the transmitter, and the correct binding procedure. I am finding the documentation on these devices to be a bit thin and i think it contradicts itself.

The cable from the Quad to the computer is good since it connected in the past. Now I can only load the firm ware.

Do i need to load the firmware every time i try to connect?

My configuration and procedure is . . . .

Arduino Mega 2560 (com3) is listed in my “Devices and Printers” control panel in Windows 8.
Port Settings are (see attached)
bits/sec = 9600 i know it should be 115200 but when I change it it does not stay and reverts back to 9600
Data bits =8
Parity = none
Stop bits = 1
Flow control = none
The advanced settings button returns an error message saying I “must have write privileges in the registry for this device in order to modify the devices advanced settings”

I click on ArduCopter V3.0.1 in version 1.2.62 of the mission planner and it asks if I want to upload the arducopter.
It appears to upload 220168 bytes to apm board:2560-2.
verified APM.
ends by recomending a live compass calibration after installing V3x.

In the terminal section . . .
Connect to APM
Opened com port
init arducopter v3.0.1
free ram:
FW ver: 120

Load_all took 11724us
3No dataflash inserted3arducopter V3.0.1]
Arducopter V3.0.1]
Arducopter V3.0.1]
Arducopter V3.0.1]?

Setup Radio
Setup] radio
radio setuo:
moveall controlsto extremes. enter to save: all controls moved

ch1: 1096 | 1947
ch2: 1101 | 1959
ch3: 1072 | 1959
ch4: 1105 | 1957
ch5: 1521 | 1529
ch6: 1163 | 1165
ch7: 1517 | 1522


Choose Flight Data section
Port = com 3 Arduino Mega (com 3)
Rate = 115200
It times out.
Details . . . See attached … or not my attachments are crashing?
No Mavlink hearbeat packets where read from this port - verify Baud rate and setup
APM Planner waits for 2 valid heartbeat packets before connecting

At ardu pilot mega.mavlink.openbg(boolean getparams.progressworkereventargs progress worker event args) in c:\users\hog\documents\visualstudio2010\projects\ardupilotmega\ardupilotmega\mavlink\mavlink.cs:line 483
At ardupilotmega.mavlink.fmprogeressreporterdoworkandparams(objectsender. progressworkereventargse. object passdata) in
c:\ SAME SAME til mavlink.cs.line311
at ardupilotmega.controls.progressreporterdialogue.runbackgroundoperation(object0) in
c:\ SAME SAME til ardupilotmega\ardupilotmega\controls\progressreporterdialogue.cs:line80

All right then good luck.

Thanks so much for the help.

@TCIII & Lonegaurd,

Thanks for all the info guys, with it i’ve managed to fix the problem (kind Of).

With TCIII concluding it being a Gyro problem I searched and found this post on DIYdrones diydrones.com/forum/topics/gyro- … er-problem, Without reading too much just saw the picture identifying the chip and saying that his had a solder short as well. Looking at my board the same was true but found pics online that did not.

So took the board to work, couldnt remove the solder so just removed the chip. Plugged in a couple times and exactly the same, hangs at either RC5 or RC7. By this point I had allready spent the week testing all the caps so gave in and just threw it in the reflow oven and low and behold it’s working again. Plugged in, connected and gives telemetry. However when I was putting the case back on I became sad when reilising I hadnt put the chip back on :cry: .

So in conclusion this fault must be a dry solder joint somewhere possibly at the actual Gyro and reflowing the entire board fixes it. But can anybody now help in the identification of the chip or even better the part number. Might put the APM in a smaller quad in a few days if no replys to see whats affected but as for now it connects to mavlink every attempt and gives full telemetry.

I have found MY solution to this problem! I copied the Driver & Drivers directories from my old XP notebook to my Vista Home laptop.
Deleted the com port driver, re-installed and the old one did the trick.
Haven’t had time to find out what I did, but I’m up and running again.
Tons of Googling didn’t help in this case. :slight_smile:


Hi fellas
newbie here.
Can seem to connect with mavlink keeps hanging at RC6 TRIMS, every time.
I can flash board ok
Using MP 1.3.2. on windows XP. APM 2.6 horizontal pin PCB, futaba 7 R617fs reciver.
Cant see any telemetry coming from board on MP.
Have goggled the hell out of it and tried all leads on this site and chased all links. no joy
tried Command prompt “rest”.
Maybe dumb thumbing it but i suspect board fault and i don’t have flow soldering machine.
Please help

You most certainly don’t need to upload firmware every time and from the sound of it you have no idea what you have bought or how it should be connected. Please read an be careful. We can’t be expected to help with day one before breakfast stuff.

Thanks for the reply Gary,
I assume this reply intended for me please address me as Emett.
I purchased a AUV flight control board, not supplied with USB cable to connect to PC.
Downloaded all latest software to interface with equipment.
thank you for the documented personnel attack on my intelligence.
I’m no computer tech and If i have missed some before breky stuff then great, it should be a 1 liner to help me on my way and not a component issue.
I have Carefully read courtesy of internet ArduCopter > common-APM 2.5 and 2.6 Overview
flitetest.com/articles/Arducopte … etup_guide

Ok my post was vague late night and frustrated.please let me clarify. delete it if required.
My APM board powers up fine, atempt to connect with ArdupilotMegaPlanner10 1.3.2, leds on boards start blinking as interrogation is working. then stops… at RC6 TRIMS…
I have also tried APM planner 2.0.9 this seems able to initial setup, install firmware and looks successful that it can talk to PC.
any help, links to read, appreciated

Still no connecting to mavlink.
uninstalled, re installed. updated. read entire Google results for anything close to my issue. diydrones to rcgroups and every blog in-between.

using MP wizard interrogation hangs at RC8_DZ, codes show this as dead-zone.
APM planner debug file

DEBUG 2014-06-05T20:13:17.302 APMToolBar: connecting to link SerialLink(0x87ad810)
DEBUG 2014-06-05T20:13:17.302 APMToolBar: updateLinkDisplay
DEBUG 2014-06-05T20:13:17.302 APMToolBar setConnection: true
DEBUG 2014-06-05T20:13:17.302 APMToolBar: CustomMode 0
DEBUG 2014-06-05T20:13:17.318 APM: getCustomModeText()
DEBUG 2014-06-05T20:13:22.771 No data!!! Attempting reset via reboot command.
DEBUG 2014-06-05T20:13:28.271 No data!!! Attempting reset via DTR.
DEBUG 2014-06-05T20:13:30.037 APM: Text Message rx’d "Calibrating barometer"
INFO 2014-06-05T20:13:30.037 STATUS TEXT: 1 : "Calibrating barometer"
DEBUG 2014-06-05T20:13:30.662 Send requestall data streams when heartbeat restarts
DEBUG 2014-06-05T20:13:31.568 APM: Text Message rx’d "barometer calibration complete"
INFO 2014-06-05T20:13:31.568 STATUS TEXT: 1 : "barometer calibration complete"
DEBUG 2014-06-05T20:13:31.568 APM: Text Message rx’d "GROUND START"
INFO 2014-06-05T20:13:31.568 STATUS TEXT: 1 : "GROUND START"
DEBUG 2014-06-05T20:13:34.177 APM: Text Message rx’d "Initialising APM…"
INFO 2014-06-05T20:13:34.193 STATUS TEXT: 1 : "Initialising APM…"
DEBUG 2014-06-05T20:13:46.271 No Data!! Tried reboot and DTR to no avail
DEBUG 2014-06-05T20:14:02.771 No Data!! Tried reboot and DTR to no avail

How can i tell if i have received a china ripoff, any help appreciated.