APM 2.5 coms failure

I have installed my new (and first) board into my Bixler2 and had a few flights to test Stabilise, Loiter, and RTL, everything worked really well (borrowed someones Bixler Parameter file)

All working good, so I ran my first mission today (start small) 8 points all close by, total trip 2.5kms.
This also worked really well.

Now the interesting bit, I came back to download the log file.
But the comms seem to have scrambled themselves a bit.

I can still read most of the text in the terminal mode, but it does not respond to the “3x Enter” anymore and Mission Planner fails to communicate too. Both the USB at 115200 & the 915Mhz at 57600 show some proper text and some rubbish.

Both forms of communication worked before, I am running ArduPlane 2.7b and Mission Planner 1.2.66

Is there a mechanical way to reset the firmware back to factory?? As I can no longer do this via the CLI


Thanks for all the help guys, sorry that I exposed so much back & forth on the main page instead of the forum.

But my solution was probably due to moisture or particles picked up during my last landing.
The grass was still wet and the Bixler2 has a downward facing air intake.

I gently cleaned the APM board with alcohol & a brush, one centremeter at a time, then baked it at 40 degrees-C for a while.

All works fine again.