APM 2.5 AC3.2.1 Throttle pulsates in Loiter

I have a problem after updating AC to 3.2.1 from 3.1.5.
When in Loiter, the the speed of the motors revs up and down/pulsate. Had none of these problems when using previous versions of arducopter.
I have downloaded the logs, and have looked into accX, accY and accZ. These seems to be inside the range specified in the wiki here at arducopter. (Log_vibrations.bin)
Please have a look at the Log.bin, and note the difference between ThrIn and ThrOut in Loiter mode.

Anyone having any idea what the problem may be?

I’ve noticed this too, immediately after the 3.2->3.2.1 update.

Curious to see the responses…

I have the same problem after 3.2.1 update with quadcopter and APM 2.6 in althold and all gps controlled modes. I found that the barometer values are very unstable in newest firmware but Arducopter 3.1.5 version is without any problem.

My APM 2.6 is doing the same thing. Has anyone found an answer?


I’ve noticed this as well going from 3.1.5 to 3.2.1 on an APM 2.5, altitude control is pretty whacked with the newer firmware!

I looked at the log for the 3.2.1 and see that my vibrations are suddenly way out of range despite no hardware changes occurred between 3.1.5 and 3.2.1. I literally flew the quad one evening, came home and updated the firmware and calibrated the new firmware, and the next morning flew with the 3.2.1 and it was all over the place.

So after doing some research and something about 3.2 in an earlier message in this thread, I changed the firmware from 3.2.1 to the previous 3.2. It flew almost as well as it had with 3.1.5!! And I DID NOT make any changes to either the hardware OR re-calibrate it when I went from 3.2.1 to 3.2. I flew it with identical settings between the two firmwares (3.2.1 & 3.2).

With 3.2 the vibrations were in the same approx range as with 3.1.5 (again - no hardware was changed), and the baro tracks closer to the GPS than 3.2.1 did, but not as close at 3.1.5 did.

I really need a working PosHold/Hybrid mode, If there were a copy of 3.1.5 that had Hybrid mode merged into it, I would be a happy camper and leave 3.2+ to the Pixhawk people. 3.2 is more stable than 3.2.1, but not as stable on this APM 2.5 as 3.1.5 is.

I’ve attached the three logs for the flights I mention above, so you can see how the different firmwares respond to the same exact hardware. Somehow 3.2.1 really narfed things compared to 3.2 or 3.1.5.

Is there somehow a setting that’s being overlooked that would allow proper operation on an APM 2.x flight controller? Or something else we are missing?



I have exactly the same thing. Super stable quad turned into a bucking bronco. Been struggling with it for ages until I saw this thread.

Can someone tell me how to go back to old firmware, please?

In Mission Planner:
Initial Setup
Install Firmware

Small print in the bottom right corner = 'Install previous firmware

Click it and a drop down list will populate with all previous APM versions.

[quote=“JoeBob”]In Mission Planner:
Initial Setup
Install Firmware

Small print in the bottom right corner = 'Install previous firmware

Click it and a drop down list will populate with all previous APM versions.[/quote]

Thanks JoeBob
Hadn’t spotted that before. Much appreciated
Will report back.

Taken me a while to get round to this but I can confirm that rolling back to 3.1.5 has solved the problem. :slight_smile:

As mentioned elsewhere, seems that’s as far as the APM s/w can go. :frowning:

I also have a Pixhawk and that flies like a dream on the latest s/w

I think I’ve discovered a solution to this problem in 3.2.1 for APM 2.x flight controllers. I just tested it and got a nice smooth flight on the same quad I was having the problems with!

It’s not a new parameter but an old one that they changed the behavior on. You need to set INS_MPU6K_FILTER to 20 or 42 rather than the default of 0. It seems that the value of 0 used to set it to the default of 20, but was changed to be an absolute value. The value of 20 is recommended for APM 2.x flight controllers.

Yeah, it seems to be THAT easy!

Let me know if you test this and the results, I’d like to know if it works for more than just my CX-20.


I have the related problem too, and I have modified the parameter as you have explained. It works.
As usually people with old APM 2.6 or 2.8 and they are mainly using 3.1.5 software, lossing sonar capabilities.
So, I would give you thanks for this information.

1 Like

Hello Dear!
Does it really work?
I’m thinking to make a downgrade to 3.1.5, but if this above solution have worked, I’ll do / fix it.
Thank you!

That setting is essentially the vibration filter.All my old APMs were set manually to 20 rather than the default 0.The default was meant to set it as 20 but did not always do so.So a manual setting can reduce the effect vibrations have on the sensors.