APM 2.5-3.1 atti and Loiter mode working crazy

I imma big problem. I use 3.1 version, everything worked perfectly, all modes, auto missions, everything was great. After ten successful flights, my qadrocopter not flown for twenty days. After a break of twenty days, I went to the meadow and took off my APM 2.5, stable mode works great, but ATTI and Loiter mode working completely crazy. I did all the calibration but still the same. Again, I installed the 3.1 version but the problem is still the same. has anyone had this problem? :confused: :open_mouth: :astonished:

That’s not much to go on although it’s likely a compass issue. If you have a log file then maybe we might be able to figure it out.
copter.ardupilot.com/wiki/common … terference

 You could try checking the COMPASS_ORIENTATION parameter and make sure that it's 0 (if using internal compass) or 8 (if using an external compass).

 It could also be really bad vibrations although that's less likely and if the altitude hold is working, it's very unlikely to be the problem.

Here’s a look at my log file … thanks