APM 2.4.8 (China board) Crash check not working

I am building a new quadcopter, first time playing small model (QAV250)
My QAV250 uses APM flight controller with M8n GPS, but I am not sure about failsafe mode (crash check).
although the quadcopter is completely leaning or flipped on the ground, I still see no failsafe triggered (motors are still working)
I am looking forward to hearing ideas from you. Thanks.

I recently updated a Pixracer that did this.
No amount of calibration or settings would fix it and it was only roll.

I eventually flashed Rover onto the board then re-flashed Copter to make sure the board was erased.
Redid my calibrations and settings and all was well.

It might help you.

1 Like

thank you for your reply. I tried to reflash Rover (car) onto my board, and then the quadcopter again. Then did all the settings and calibrations but the Crash-check was still not working.
Do you think it is not supported for my APM version 2.4.8 ?

I looked at your picture again and this is an APM. Sorry about that.

Crash check and fail safe are two entirely different things.

Crash check means the flight controller has detected a crash.

Fail safe means the flight controller has detected an error with the RC radio (loss of signal), battery (low voltage, low remaining capacity). What the flight controller does with the fail safe is up to you.