APM 1.4 (1280) Help

I acquired a older UAV with a APM 1.4 with 1280 chip. Trying to get Mission Planner to update firmware or even connect. Seems everything is for the 2560 chip. Is the APM 1.4 with 1280 chip still supported? If so, is there a specific version of Mission Planner I should be using? I have the latest version now (1.3.3). Any help would be greatly appreciated. Would rather not scrap it and have to buy something more current.

When I run the initial setup – > Firmware I get “Epprom format changed (107 vs 120)” dialog box pops up and asks me if I want to continue. Is this normal?

If I say yes, I get
"Failed to download new firmware : System.UniFormatException: Invalid URI: The URI is empty.
at System.Uri.Create.This(String.uri, Boolean dontEscape,UriKind uriKind)
at System.Uri.ctor(Strin uriString)
at System.net.WeRequest.Create(Strin.requestUriString)
at MissionPlanner.Utilities.Firmware.update(String comport, software temp, String
historyhash) in c:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\Utilities\Firmware.cs:line 491"

Can someone interpret this ?


Hi John,

APM 1.4 with 1280 chip is still supported, this error “Failed to download new firmware : System.UniFormatException: Invalid URI: The URI is empty.”

For me it sounds like the firmware link is not working, maybe internet connection issue, or the firmware you are trying to use is no longer available. I would recommend to install MP 1.3.4, download the firmware to your computer and install it using load custom firmware option.

Firmware can be downloaded from here:

To activate the “load custom firmware” option in mission planner, go to config/tuning, planner, check advanced view (at bottom right), and return to initial setup, install firmware.

Thanks for the reply. I tried what you suggested and every firmware from the list I get “Firmware is to big for a 1280. Please upgrade your hardware!!” I tried all the way back to the “2013-03” folder “APM1-QUAD” folder. No luck. Is there a place I could find older firmware than that? That would fit on my 1280?


The only way you are going to get the Ardupilot firmware to load is to create a custom version of the code with reduced functionality which reduces the size of the code.
This means you will have to use the Ardupilot custom version of the Arduino IDE 1.0.3 (http://ardupilot.com/downloads/?category=6, eliminate some functions you do not need, recompile and then attempt an upload. Repeat the process until the code will load.

I have already tried that also. I have disabled everything I dare to disable and I still can’t get it to compile small enough to fit.

Does anybody have a working .hex file that will fit on a APM1.4 atmega1280 FC?


My apologies, Rogelio asked me about this earlier in the day and I mis-read his question. The code has not fit into 1280 based APM for about 2 years even if you disable everything. The code will still run on the 2560 version of the APM1