Anything new with getting ROI working?

Tried it several times today without success; using DP v2.8.6_RC3 The other functions I tried worked well!

Either I don’t know how to use it or it is not yet implemented?

Have any of you gotten it to work?


Yes, this does work though not if I use Follow Me first. If I use Follow Me strange things happen like it will face 180 degrees the other way or always point back at me during an Auto Mission.

A good indication that it’s hosed is that you can not control the camera pitch anymore.
Also if you disconnect Droid Planner and then start the copter and fly the mission it should work just fine.

For some reason on some tablets the Follow Me mode does not shut off.



Thanks for the reply.

When you say it works does the ROI command (new ROR WP) have to be inserted after each regular WP or will it continue to point correctly with only a beginning ROI WP?

Also how does on turn off the ROI in a mission or set another one during the same flight. MP seems to have that ability, does DP?


In the ROI command you set the point and also the height of the subject you want to capture. The only rule is that you need to have at least one way point after that command for it start pointing in that direction. Also note that it will start going to the next way point as it positions the ROI. So it may take a few seconds for the copter to turn and point where you want it. You may want to set a small way point so the camera is turned before you actually need it to point.

To cancel ROI you need to set a ROI with Lon/Lat/height to zero and have one way point after that otherwise it will not cancel.


Mike thanks for the helpful reply.

After the “cancel ROI” and waypoint, then it seems a new ROI be implemented in the same manner?

Correct, as ROI with version 3.2 now persists until they are changed or canceled.