Anybody else actually using an Edison on board? Having issues

I received my unit last week - finally. Pretty impressive quality and a good selection of included accessories. The hex screws on the bottom cover could go away however, now that I’ve had to get into this thing several times.

Hex Running 3.5 RC3, SF11 Lidar, PX4Flow, 6S, Mauch Power, Cube w/ Edison Base and Here GPS.

ANYWAY - so last weekend, I get everything setup, install the Edison, install APSync. Go to connect USB to the Cube and it just clicks (audible) and flashes a couple of times. So I connected the battery then connected to USB and could connect through Mission Planner.
I loaded up Copter 3.5 RC3. Started all the calibrations…seemed slow. Started compass calibration (on unit) and it took me about 45 mins to finally get though it. During the process, I got a couple of “NO SDCARD” messages flashing up.

I managed to get everything going, all tweaked and took it for a spin. Seemed fine.

Now it’s a week later, I figured I’d send it up tonight. Power it up, let it boot - hit safety switch. When I go to arm it doesn’t spin up and in a second or two disarms - locks - no telemetry and I cannot connect.
Tried multiple times and ways. Checked all connections etc. Couldn’t get it to go…and it just got worse until it would lock shortly after boot.

I took it all apart and reseated everything - still the same.

Finally I yanked the Edison and everything worked. Now it’s raining so I can’t fly it but it does arm and spin motors, and doesn’t lock.

So there appears to be some sort of issue, at least with my setup.

I made a dump of all logs here: CubeLogs

Power is a real issue for these boards. That “clicking” you heard is often a sign of insufficient power.

I find plugging it into a chunky wall-wart makes things reliable here.

I would definitely continue to experiment with different powering arrangements.


With all the sensors you have plugged in I’m hoping you are not plugging in anything to telemetry port 2 if you are that could be problem Edison is using telemetry 2

No : ) Everything but the FrSky telem cable (currently plugged into the GPS2 - another issue I’m about to post on) and the Sik are I2C and powered with a separate supply where I can.

I wound up using a powered USB hub but it still wasn’t enough to boot though the cube (with the edison). Std USB boots fine without the Edison.

I am running an Edison with here rtk and second m8n. Telemetry to gcs through the Edison and frsky telemetry through telemetry 1 port. Works perfectly every time. The only issue is wifi range, switched to an external antenna version with a slight improvement but still very short range, 100 meters or so. I also have a large hex flying with a P2, TX1 telemetry and video through telemetry 2 and frsky telemetry on telemetry 1


Thanks Randy. I’m posting a kind of “here’s my Pixhawk 2 Build experience thing”.

I did however get this worked out, it appears it was EKF3 on the 3.5RC builds.

Khmmm…and the answer to your question is;no,almost no one is using it,just wear it as a fancy necklace…