Any Freelander PX1 users?

Hi, a quick intro:

I’m from South Africa and enjoy RC (doesn’t everyone? :smiley: )

I bought a Freelander PX1 7inch tablet from DealExtreme to run Droidplanner (v1.2 installed)

The app runs perfectly, but the software (I think) does not communicate with the usb dongle when plugged into the PX1. I do not get the pop-up question I get on my Galaxy S2 (Droidplanner seems to work fine the S2). The LEDs do flash when plugged in to the PX1, but I keep getting the “DISCONNECTED” voice-promt when I try to connect.

(I’m running Android 4.2.1 on the PX1, tried to update but no success yet.)

Has anyone tried Droidplanner on the Freelander PX1 with success?

All help will be appreciated.

The PX1 is a MTK8389 chip based Tablet.

After some internet searching I did the following:
Rooted PX1 with Framaroot 1.6.0 apk
Fixed USB host issues with USB HOST CHECK apk
Rebooted the PX1
That solved the problem!

Hope this helps someone in the future.

It looks like you solved your problems. I’m happy to hear that, and thanks for sharing the info for others.

At a first look I though you where talking about PX4 the board not the tablet :slight_smile: