Anoying Esc beeping

After some time I returned to my 450 heli project. Currently I am doing the swashplate setup, but as soon as I power up, the Esc starts beeping and I can’t find the reason why.
It’s really anoying.
I have already disabled the safety switch, but for some reason the Esc is not happy.

Please provide a param file. That is the best way for us to see if you have the firmware configured correctly. The other thing is that we need some details on the hardware setup
Controller (i.e. Pixhawk, pixfalcon …)
Tx and Rx and whether you are using an PPM encoder
ESC model
What port is ESC plugged into



My setup is as follows:

  1. FC: Pixhack v2.8.4,
  2. Rx: Frsky X8R (no PPM encoder)
  3. Tx: Frsky X9D+
  4. The ESC came with the used Trex 450 clone I bought few years ago, with no name on it :frowning:
    The ESC is plugged in port 8

Sorry, I uploaded a wrong param file.
I was sure I had a saved param file on my laptop as I was trying to upload Chibios, but had problems and switched back to NuTX, but I can’t find it anymore…
This will have to wait, as I can’t get to the FC for a while (until next weekend).
Bill thanks for your help, but I do understand that withou the param file it would be shooting in the dark.

no problem. Just looking at your set up, it seems like everything is hooked up like it should be. The only thing I think that could be causing an issue is if the pixhack is sending a high PWM on power up which would be caused by the Servo8 being reversed. I can’t remember if we hard coded the RSC output to normal only or not. When you can get me the param file, we can take a closer look.


Here is my param file.
Just noticed, in the param file, that it says that the vehicle is multi-rotor, although the frame says heli.
At first I thought it was a QGC thing, but MP says the same.

Trex45_180915.param (22.9 KB)

Your servo 8 is putting out too high of a value for the ESC to initialize. These should be 1000 and 2000

1 1 SERVO8_MAX 1900 4
1 1 SERVO8_MIN 1100 4

Also if this is a flybar helicopter you need to zero out the ATC_RAT P and D gains for pitch and roll.

Hi Chris,

I changed the SERVO8_MAX and SERVO8_MIN to 2000 and 1000 respectively, but the problem still persist.
First I get a single beep from the ESC and then when the FC finishes booting, the ESC starts (fast) beeping…
I downloaded the RC10 beta version, so here is my new param file

Trex450_180915_RC10.param (22.9 KB)

I also set the P and D gains to zero.

Any ideas what could be wrong?

In order for the ESC to be beeping, that usually means it’s getting too high of a throttle signal for it to initialize. Most helicopter ESC’s look for a signal from 1000 to 2000, and if it’s above a certain value (probably 1050-1100 pwm) it will fail to initialize and constantly beep to let you know it never armed. So make sure you don’t have any mixes in the RC that is preventing the signal out from the RC from going to the low calibration value of the RC8. It looks like you might have a FrSky radio (looking at the RC cal values) so page thru the screens to your servo outputs and look at Channel 8 to see if it’s not at -100. It shouldn’t make any difference but I usually set the RC8 trim value to the minimum calibrated value too.

We already covered the SERVO8 settings, so it has to be the RC.


Thanks for your valuable help :slight_smile:
You are right, I use the Frsky X9D Plus. AFAIK, I have no mixes in the radio, but will check anyway.
But, at the time, I didn’t had the radio turned on, as I was only setting up the swashplate.
Could that be the problem?

Yeah, I recognized the cal values from a FrSky running with SBus.

I shouldn’t matter with the RC off. Is your failsafe set so with no RC that the receiver is holding a value on Channel 8? Or are you using No Pulses for RC failsafe? With the radio off it can’t be a problem with a mix in the RC or settings problem there. Try connecting with the RC and see if it goes away. It could be the ESC beeping to tell you there is no RC signal.

I think I have an Align ESC in one of my flybar 600’s that will do that until the RC is connected.

It is set to No Pulses for all my heli/quads.
Will try this weekend with the RC on and let you know…

There is a little bit of a bug in ArduPilot’s handling of No Pulses with SBus. We have to take a look at that as sometimes, especially with FrSky receivers, if RC is lost it will shut down the engine momentarily on re-bind. Which means for a combustion engine heli (which I fly) it will shut the engine completely down and the heli is in autorotation.

It has been that way for quite awhile but we need to improve the handling of that. Have not gotten around to looking at it yet. Personally I don’t like the No Pulses, and have always preferred to use “Hold Last Received position” on the servos in a RC failsafe. Because not all radios are the same for No Pulses.

I have tried with my RC connected, but the beeping didn’t go away. This one is driving me crazy…

Ok, I finally nailed it (or so)…
After trying all the weird things that occasionally came on my mind, disabling failsafes, trying a different battery, connecting my RC, disconnecting it, casting same spells, lighting a candle, pulling my hair, etc, etc, it came to me that I didn’t try the simplest thing, to lower the servo8_min value.
I set it to 950 and the magic begin, the ESC stopped beeping, instead of a single beep, it gave me the standard three beeps (for my 3S battery) and no more beeping!
And then the funny thing started, I increased the min value in steps by 10, and go figure… It even accepted the 1000 as a low value.
It seems that it was stuck in a void for some weird reason and that I was able to bring it back :slight_smile:
So, thanks Chris and Bill for your help (I did learn some valuable things from your replies after all).

I believe you need to program your ESC.

Connect the ESC to the receiver and power it with the channel where you plugged it high.

After the initial beeping, move the channel to max, and try to hear some different beeping and then move to minimum and it will make another kind of beeping. Power off and disconnect the ESC from the receiver and restore the connections to the flight controller.

Check the max and min values of the channel you plugged the ESC and those values will be the CH8 MIN and CH8 MAX

I did try it with a ESC_CALIBRATION set to 3, but it didn’t work…
Will follow your suggestion and connect the ESC to the receiver.
Thx for your help.

Trying to resolve this I actually found a card saying Tarot Pentium-40A ESC, so now I know which ESC I have on the heli.

Hi Everbody,

I m new to ardupilot and I have those hardware, can i success with those, help really appreciated.

Turnigy 6x TX and RX
Arducopter 2.5
Mission planner software
250 size traditional helicoper with 3 swashplate servos and an emax analog tail servo

I mean especially 6 ch controller enough or 8 ch is a must?