Another verify failed problem

Hi everybody, I am new to all this and need some help. I got a APM 2.8 and wanted to flash firmware APM copter 3.5.5. Quad. No matter what version or computer I am using, I am always getting

Upload succeeded but verify failed: exp D3 got C3 at 146

What I have done so far:

MP 2.0.24 on Ubuntu 16.04 runs great but the error above mentioned
MP 1.3.53 on Ubuntu 16.04 running with mono runs great same error
MP 1.3.55 on Windows 7 (Virtual Machine) runs great same error
At the very first beginning I added sbus support by flashing which worked fine.

Also tried to flash other firmware e.g. plane, does not work either. Now I am stuck! Does anybody have any idea what could be wrong? Thanks for some help


Its been a while since I’ve played around with ArduCopter / Pixhawk / APM, but I thought APM could only update to 3.2.1 max (I think partly due to size) and hardware capability. If you do a search on latest firmware APM 2.8 can update to you’ll find a few references to this. Good Luck!

nvpowerdoc was right. APM 2.8 does not support the latest arducopter versions. Copter 3.2.1 is the latest firmware supported by the 2 series boards (due to the massive size of the code)

You can either use Mission Planner (download it from the ArduPilot Website) - it will find the latest firmware available for the 2.8 board

or go to - where you will find anything to know

Good luck!

Thanks for the tips, but MP detects automaticly that the board is outdated and downloads the latest firmware for the APM 2.8. But I also tried to download it manually and install it via custom. Same error! :thinking::disappointed_relieved: