Another Mini-Talon QuadPlane and a problem

I just wanted to show my Mini-Talon QuadPlane.
It uses T-Motor MN2213 950kV motors with Graupner 9x5x3 e-props for lift.
The lift motor ESCs are FlyColor 30A optos with BLHeli firmware.
The forward flight motor is a LDPower 2814 1100kV with an APC-E 9x6.
I only had a 80A ESC lying around, so I used it for the forward flight motor.
The whole thing is powered by two 4000mAh 4s 25C lipos in parallel.
For power distribution, I used a pair of cable, running from the front motors to the rear motors.
I then pealed away the insulation where needed to solder the power module and the 80A ESC to the cable harness.

AUW is around 2100g
I made the arms from 4x30mm plywood strips.
They flex a little, but hover flight is very stable, even in gusty winds.

I have one problem with the lift motor ESCs. I set ArduPlane to Oneshot125 and did the ESC calibration. All motors work just fine, but the ESCs never arm all at once after pressing the safety button. It is always a different order and sometimes the last ESC arms after about 20s. What could be the cause of this behaviour? I looked at the output values with MissionPlanner and all four output values are the same. After pressing the safety button, they are still the same, just a little bit higher. FC is a RTFHawk.
Here are a few pics:

1 Like

Hi Sebastian,

Nice design using 3-blade props. I’ll have to keep that in mind if my 10" props don’t work out.

Are you saying that you can hover fine when the Oneshot125 feature is disabled? Or that you have to wait before all four ESCs are armed? Have you tried it with the Oneshot feature disabled? Can you post a log?

I had that issue in the past with my racer and cuad firm, I disable oneshot and the issue goes away, It suppose to be solved now in multirrotors firm but I have to give a try yet, perhaps in cuadplane is still there because is not common oneshot, my experience was that you can fly then without issues but, just in case, I disable it.


I just returned from the field. The MT did its first full flight and is still in one piece! :smile:
I disabled the use of the airspeed sensor and set FBW_MIN to 14m/s to be save. The wiki is not 100% clear about the behaviour after switching from QHover/QLoiter to FBWA. It says the Quadplane will continue to hover until the pilot raises the throttle, but since it is not possible to hover without having the throttle in mid position, the Quadplane starts to fly forwards immediatly.
The first few transitions were no problem, but then the wind picked up and I was not able to make the MT descent in QHover mode. I had to switch to QStabilize and even then I had to lower the throttle below 1/3rd to bring it down.

I have Oneshot125 enabled and with that I have to wait quite some time before all ESCs are finished arming. Once all ESCs are armed, I can arm the aircraft and fly in VTOL modes without a problem.
It seems I can not post a log, because there was none written. I checked the logging parameters and will change the sdcard before the next flight.

The MT hovered well with two bladed T-Motor 9.5x4.5 props (they are 9inch in fact), but it was really noisy. Now it has more thrust and is much quieter.