Another ESC issue

I read the thread on the ESC not arming. I just got my Pixhawk and am setting it up. I have a hexacopter that was running on APM 2.5 just fine, but wanted to upgrade to the Pixhawk. I hooked everything up and all seems to be well, except the ESC’s won’t arm. I assumed because I had already calibrated them with the APM that it would not be required. I tried to calibrate through the Pixhawk and could not. I then manually calibrated. They would still not arm. I tried manually calibrating with a higher low throttle, but still would not arm. I tried plugging in a servo to the output for the #1 ESC and it does not move. I checked for power on the rail and it is only.50 millivolts. I tried powering the rail, however it was from a separate battery and still no servo movement. It is as though the PWM is not going through to the pins. When I connect on Mission planner I can see the output go up and down with throttle movement after arming.

I am using the power module from the APM, is there any difference between the APM one and the Pixhawk one?

Something that might not be apparent to you is that you need to use the Safety Switch as part of your calibration process. Watch this video

I did use the safety switch.

I just switched the power modules, and it made no difference. I did not think it would as the Pixhawk is powered.

I still don’t have any power on the rail. Could that be causing it? I have all the red wires from the ESC disconnected, as the Pixhawk through the PM is supplying the power.

Do you have a ground connection from the ESC / PDB back to the Pixhawk?

Yes the ground is there, but no power. I made a special harness so that I could power the servo directly from the battery, and then the servo will move. I removed that and then I tried the calibration process again and was able to get the calibration done.

After the calibration was done I could directly control the motors from the transmitter.

I unplugged and then plugged back in. As soon as I hit the safety button, the ESCs go into failure mode, just beeping. If I don’t hit the safety button the just beep slowly, like they are waiting for a signal. As soon as I hit the button the start beeping rapidly. These are turnigy plush 40 Amp ESC’s.

I tried doing the calibration again, and once again it works. But I still get a failure as soon as I hit the safety button.

As I continue trying more things.

I plugged in a castle ESC (did not calibrate it) and motor, power up and it arms normal, push the button, arm the copter and raise the throttle and it spins the motor just fine, meanwhile all the Turnigy ESCs are beeping failure code.

I am starting to run out of ideas.

So i guess the question is “what does all the beeping from the Turnigy ESCs mean?”. So I guess you’ve already identified that before you push the safety button there is no signal being output from the pixhawk (which is normal) so the ESCs provide that slow single beep.
So the next set of beeps after you push the safety button is probably a complaint that the signal provided is too high. They want a lower value for at least a moment before they will arm.
If you have a receiver with individual channel outputs (i.e. not PPMSum) then you could try connecting the turnigy ESCs to the receivers throttle channel (perhaps channel 3?) and calibrate them that way.

Randy, thank you for chiming in, but I did get the Turnigy ESCs to calibrate. But they won’t arm doing the normal startup

OK, I think I figured out a workaround. I first plugged in the USB so as to power up the Pixhawk. Pressed the safety button, then armed it. Put it at full throttle, then plug in the battery. After the ESCs made their high throttle beep, brought the throttle down, they then made the low throttle beep. Unplugged everything, plug the battery back in and now the ESCs arm after pushing the safety button. (So essentially using the Pixhawk in normal mode to do the calibration)

Took it outside for a late night test hop and all is well.

We talked about this last night on the dev call and stand by for a fix to the problem. We going to bypass the safety switch when the Pixhawk powers up into calibration mode. This actually requires a fair bit of code so it will be a few days but we have a fix in the works.

I am really stumped at what I hope is a simple oversight on my part. I have a Pixhawk with the latest stable plane 2.7X FW. I am able to calibrate the radio and can see, through telem., that Ch in and outs match. I am powering my RC Rx through the Pixhawk output rail which is powered by a BEC at 5.1V. All is great EXCEPT, I can’t seem to get power to my servos or arm the ESC.
I have tried a servo attached directly to the RC Rx and it works perfectly. So there is sufficient power, at least to the PPM connector.
There can only be two things wrong in my opinion. 1) no power to the servo connections 1,2,3,4 or 2) no signal to the same connections.
Btw, I get a solid green light on the Pixhawk.
Any ideas greatly appreciated.