Analog RSSI ChibiOS

been out flying today on 3.8.5 all good rssi working fine
got home and i seen Plane 3.9.0 stable had been released
so updated to Plane 3.9.0 stable released ChibiOS Build
rebooted the cube power it up checked over the config all good
power on the TX all servos worked flight modes worked
but no rssi so i checked the config all good as it was before


here is the bin and logs and config file


after all that went back to 3.8.5 all work as it should
so then i tried 3.9.0 STD build and it works this has got me beat

STD bin and log

just test this on 2 other planes running cubes under ChibiOS Build Analog rssi not working works fine under 3.9.0 STD build

For me it is also a feature that I can´t miss.Now I installed the NuttX version on a fresh build.
Searching for the issue:

SBUS out and ADC is still open on this list. So RSSI can´t work …
In case of analog RSSI and minimOSD the OSD ADC input could be used …

I got the same issue. Where can i get that 3.9.0 STD build

Depends on your hardware: The NuttX (Std) firmware is only avaliable for the older Pixhawk family boards.
When flashing via MissionPlanner it asks to install ChibiOS…No!

Thanks. Got it running again.

Running arduplane 3.9.1 no chibios and the rssi is not working. Any fix on that?

Ok, the non Chibios works. Had to do a resetting :slight_smile:

I’ve fixed RSSI on IOMCU with ChibiOS for the 3.9.2beta2 release
Cheers, Tridge

Thanks Buddy for your work

Thanks! Is the ADC6.6V for analog airspeed also useable in this release?

yes, it should be, please test it though

Many Thanks, on the bench it looks fine (analog RSSI and analog Airspeed). I will need some time rebuild my plane to do a flight test.

1 Like

Jep, it seems to work alright. Thanks

1 Like