An Open Source Frsky Telemetry Script for the Horus X10,X12 and Taranis X9D,X9E and QX7 radios

Thank you so much Alex. It works a treat!:grinning:

1 Like

Alex, many many thanks, works great on my x9d. One question, I noticed that altitude is shown as MSL and not AGL, and I found this post

which suggests that changing the DEV _OPTIONS parameter will change that displayed altitude to AGL (relative) alt, which it did for MP when I made the change but not with the telemetry script. Is there something else that needs to be done with the telemetry script config to make this work?

You have both:
right side on the glass cockpit is relative.
top left is absolute gps reported altitude.

Alex do have list of frsky ID list
i may have some sensors that are clashing with each other
i have issue with one of my FLVSS if i plug it in the gps stops working

Hi Colin,
GPS sensor comes from ardupilot, it’s not clear to me how you wired your system. Are you using the mavlink to passthru firmware on a teensyor it is a direct connection via a max3232 cable?
You should get it working without my script running and once frsky IDs are correct add the script to the equation. If IDs turn out to be clashing you can change them with the proper frsky tool.

i have 3 FLVSS i can plug 2 off them in and it gps works ID 10 and 11.
but if i try to add the last one it stops and i have tried to change ID just stops pull it out it works thats with out your script running5d38e1e0f34f87fecbd429335da641684cfe0625_2_690x303

Great! Thanks a ZILLION

1 Like

mhmm, honestely I have no idea why the GPS sensor would stop, did you solve it in the meantime?

nop been trolling the net no good yet
is there a limit sensors ?

I don’t think so, but I personally never tried more than 2 FLVSS + FC

there is a limit in OpenTX to 32 sensors max

there only 25 on my one so not that

well looks like it may have something to do with gas suite if i pull out the gas suite and plug in 3 FLVSS all works but soon as i plug in the gas suite the gps stops

to recap:

  2. FC + 3 FLVSS: GPS OK

Do you have the gas suite script running while you do the testing?

1234 is the way it works
no i don’t have the script running
the only time i run the script is to set the prams or set the smart port ID that is set to 17

i did try it with FC + 5 FLVSS and it worked worked with out the gas suite

Colin, does passthrough telemetry work in use case 4, or both passthru and gps do not work?

passthru works just the GPS stops

There might be an issue in physical ID 0x1B being used by both the gas suite and ardupilot.
I think the gas suite uses physical ID 0x1B by default, at least this is what the GAS suite lua script uses.
This also implies that the suite responds to polling for ID 0x1B just as ardupilot does.
From the docs it looks like you can change the gas suite default physical id with the FreeLink app.


I’d try with an ID between 10-20 (before changing it better take note of the current one even if the “default settings” button is there)

These are the sensor IDs that OpenTX knows about.

// Default sensor data IDs (Physical IDs + CRC)
    #define DATA_ID_VARIO             0x00 // 0
    #define DATA_ID_FLVSS             0xA1 // 1
    #define DATA_ID_FAS               0x22 // 2
    #define DATA_ID_GPS               0x83 // 3
    #define DATA_ID_RPM               0xE4 // 4
    #define DATA_ID_SP2UH             0x45 // 5
    #define DATA_ID_SP2UR             0xC6 // 6

If everything else fails you’ll probably need a logic analyzer to dump the traffic and debug it.

i did try other ID
Hmm i think i may have logic analyzer
i did have an issue with ardupilot on the I2c locked up
and i had to run a dump for Andrew Tridgell and he fixed the issue i was having with i2c bus

Just curious, what IDs did you try?

from this image looks like the default is 22 not 0x1B :frowning: