An Open Source Frsky Telemetry Script for the Horus X10,X12 and Taranis X9D,X9E and QX7 radios

@yaapu

Hi Alex

Could you please test https://github.com/ArduPilot/ardupilot/pull/10499

Hi Daniel

Your English looks pretty good to me.

Hi Alex, your new Taranis scripts look great. I’m visiting my son and his family in Australia, so cant do any flying or testing for a while…

Daniel, I suggest you read the wiki then ask any questions that remain unclear and we will try to address them.

Good morning to all and thanks for the quick reply. I like to look at the Wicki again. I’ll contact you again and give feedback :). I thank everyone for the helpfulness. I wish you all a nice day

Hi Luis,
sure, I’ll try it later today!

Alex

Hey I’m it again :slight_smile: So I’ve read everything and again have a question about this: I find neither the frsky.h file nor the frsky_sport.ccp where exactly do I have to search these files?

I’ll answer in the other thread

Thanks YAK-54,
The video help me to better understand the telemetry but for me it is still a steep learning curve. I know this is not relevant to yaapu but the telemetry has helped. I am slowly coming to the conclusion that my Pixhawk 2.4.8 is dodgy, I can make my quad fly with it but it does not work like my other 3 Pixhawks and unfortunately PX4Pilot is no longer available. So again thanks for the help, I have started 2 new discussions asking for help with issues but no one has replied.

I have a problem with downloading:

not quite, flight time was still corrupted, now should be “really” ok :slight_smile:

https://drive.google.com/open?id=1fqLpIONOMw45TwxauQpemXdXLrGqyYJl

I always get a message WHOOPS there is a problem with Preview. If I click download I end with a folder called SD but I have no clue was to where to go from there.

Hank,
the link points to a zip file you have to download.
The content of the SD folder inside the zip has to be copied to your radio SD card, for file name and folder structure look at this

Alex

@ThePara, I created a PR for this, mine is just one of many possible fixes, at least now the issue is registered as such :slight_smile:

Hello Alex Apostoli. I am trying to get telemetry data from the Radiolink Minipix flight controller (Arduplane 3.9.6) with Serial 2 via S.Port receiver Frsky R9slim + using the max3232 board and the diode using your circuit, on the screen of the Frsky Taranis Q X7 hardware (OpenTX 2.2.1). But I have a few problems that can not be solved. 1. After installing Lua Script and searching for sensors, 13 sensors are displayed. Of these, only RxBt and RSSI are active. The rest are not active, there is no sign * opposite them. 2. After the remote control and flight controller are reconnected, an error appears on the equipment telemetry screen. Tell me what I’m doing wrong.IMG_20190322_061802 IMG_20190322_061839 IMG_20190322_062035 IMG_20190322_061902 IMG_20190322_062053 IMG_20190322_061927 IMG_20190322_062109 IMG_20190322_062155 IMG_20190322_062125 IMG_20190322_062212

As previously stated on several places, including the wiki that Alex wrote, you don’t search for sensors.
Following the steps on the wiki is not optional.

Good day. I tried different options to enable the script. 1. First deleted all sensors. Further included a script. Checked the appearance of sensors. They did not appear. 2. Removed all sensors. Included search for sensors. Install the script. Sensors appear, but only two of them are active RxBt and RSSI. 3. Removed sensors. Included the script. Started the search for sensors. Only two RxBt and RSSI and sometimes GPS appear. Which of the scripts I have described is correct?

Moved to the appropriate thread

Following the steps described here https://github.com/yaapu/FrskyTelemetryScript/wiki has enabled lots of users to get this running.

Hi, most likely your cable is not working.
Remove the script from radio and delete all sensors.
If the cable is working and you have setup the serial port with protocol 10 a sensor discovery now should get RxBt, RSSI and GPS. If you do not get GPS something is not working.

I understood you correctly that if the cable is intact, then after turning on the remote control I turn on the flight controller, then I go to the telemetry tab in the control panel and turn on the search for sensors. After finding them, I should see RxBt, RSSI and GPS. In this case, the script should not be included.

Yes, when the script is not runnig (to be sure undefine it and delete from radio) and everything else is working and wired (flight controller -> cable -> RX --> radio link -> TX) a sensor discovery should get you RxBt,RSSI and GPS

Edit: a sensor discovery should also show all standard “physical” frsky sensors you might have chained on the s.port bud like FLVSS for instance

I’m not sure if it’s a bug or my tx, but when Disarmed message flickers with black frame, few pixels stay black just above the word. X9D+ with latest firmware.

Good day Alex Apostoli. After numerous and unsuccessful attempts to obtain telemetry data on the screen of the remote control, Taranis Q X7 decided to experiment with the script files. At first I copied files onto SD fs as in the instructions, but an error occurred when starting the script and turning on the flight controller. Then I left only the .luac files on the SD, the script was installed, no telemetry data was received, and there was no voice message about the script launch. The next time I placed on the SD card only the .lua files and about a miracle, telemetry worked without problems. My configuration: Flight Controller Radiolink Minipix (Arduplane 3.9.6); MAX3232 with diode on the output side of the receiver (connection to the receiver via one wire to S.Port, the ground wire is not used); receiver Frsky R9slim+; Frsky Taranis Q X7 transmitter (OpenTX 2.2.1). Thank you all for your help and all the luck.

Hi, are you referring to this?
image

if so that’s the home icon
image

But if it’s something else please take a picture :slight_smile: