An Open Source Frsky Telemetry Script for the Horus X10,X12 and Taranis X9D,X9E and QX7 radios

the new version is a “drop in replacement” of the older one, if you had the current release working this new beta should “just work” :slight_smile:



The new script just has an extra view that allows integration of extra FrSky sensors. Which is nice for helicopters or other combustion engine aircraft. The first view requires no different setup than before.


Great video Chris, thanks.

I could almost feel the weight of your heli from Italy :slight_smile:

QX7/X-Lite version is almost ready for testing

default view

dual battery view

mavlink to passthrough custom view

custom frsky sensors view

Hello my Name is Daniel, I’m new on this side and I need your help please. I’m sorry for my bad English. its a lot of years, when I was @school ;). Now my Question:

I programmed a Horus X12s and a Teensy with the right hex file. the Lua script starts great all sensors are found but not read. Most have an id the rest is running at id 0. On the Horus runs open TX 2.2.3 and on the Pixhawk runs ardupilot. My problem is that the sensors from the LUA script are not read out and the message comes lost sensor. I’m grateful for your help

Hi Daniel,
there’s a blog here on discuss dedicated to the teensy wiring and configuration, I’m sure the author of the firmware @Eric_Stockenstrom can guide you through the setup process.
Once the teensy is working the Horus widget should “just work”




Hi Alex

Could you please test

Hi Daniel

Your English looks pretty good to me.

Hi Alex, your new Taranis scripts look great. I’m visiting my son and his family in Australia, so cant do any flying or testing for a while…

Daniel, I suggest you read the wiki then ask any questions that remain unclear and we will try to address them.

Good morning to all and thanks for the quick reply. I like to look at the Wicki again. I’ll contact you again and give feedback :). I thank everyone for the helpfulness. I wish you all a nice day

Hi Luis,
sure, I’ll try it later today!


Hey I’m it again :slight_smile: So I’ve read everything and again have a question about this: I find neither the frsky.h file nor the frsky_sport.ccp where exactly do I have to search these files?

I’ll answer in the other thread

Thanks YAK-54,
The video help me to better understand the telemetry but for me it is still a steep learning curve. I know this is not relevant to yaapu but the telemetry has helped. I am slowly coming to the conclusion that my Pixhawk 2.4.8 is dodgy, I can make my quad fly with it but it does not work like my other 3 Pixhawks and unfortunately PX4Pilot is no longer available. So again thanks for the help, I have started 2 new discussions asking for help with issues but no one has replied.

I have a problem with downloading:

not quite, flight time was still corrupted, now should be “really” ok :slight_smile:

I always get a message WHOOPS there is a problem with Preview. If I click download I end with a folder called SD but I have no clue was to where to go from there.

the link points to a zip file you have to download.
The content of the SD folder inside the zip has to be copied to your radio SD card, for file name and folder structure look at this


@ThePara, I created a PR for this, mine is just one of many possible fixes, at least now the issue is registered as such :slight_smile:

Hello Alex Apostoli. I am trying to get telemetry data from the Radiolink Minipix flight controller (Arduplane 3.9.6) with Serial 2 via S.Port receiver Frsky R9slim + using the max3232 board and the diode using your circuit, on the screen of the Frsky Taranis Q X7 hardware (OpenTX 2.2.1). But I have a few problems that can not be solved. 1. After installing Lua Script and searching for sensors, 13 sensors are displayed. Of these, only RxBt and RSSI are active. The rest are not active, there is no sign * opposite them. 2. After the remote control and flight controller are reconnected, an error appears on the equipment telemetry screen. Tell me what I’m doing wrong.IMG_20190322_061802 IMG_20190322_061839 IMG_20190322_062035 IMG_20190322_061902 IMG_20190322_062053 IMG_20190322_061927 IMG_20190322_062109 IMG_20190322_062155 IMG_20190322_062125 IMG_20190322_062212

As previously stated on several places, including the wiki that Alex wrote, you don’t search for sensors.
Following the steps on the wiki is not optional.

Good day. I tried different options to enable the script. 1. First deleted all sensors. Further included a script. Checked the appearance of sensors. They did not appear. 2. Removed all sensors. Included search for sensors. Install the script. Sensors appear, but only two of them are active RxBt and RSSI. 3. Removed sensors. Included the script. Started the search for sensors. Only two RxBt and RSSI and sometimes GPS appear. Which of the scripts I have described is correct?

Moved to the appropriate thread

Following the steps described here has enabled lots of users to get this running.