Altitude Max of 1000M in V1.2?

Hi all,

I’m in Colorado and trying to use DroidPlanner for planning fixed-wing missions on a Bixler 1.1. Arthur - this app is incredible, thanks for all of your hard work.

In Colorado we’re at roughly 1,519 meters in altitude. My first test was yesterday - I set a handful of waypoints around 50 meters and I thought those were AGL (above ground level) relative to the home position from the GPS lock on the APM. When I put the plane in Auto mode it started a very rapid decent. I read a bit more in the forums and it sounds like the waypoint altitude setting on DroidPlanner are all absolute altitude - not adjusted for ground level.

The problem is that the maximum altitude point on the slider is 1000 meters. Does anyone know how to increase this max?


Do you have the older apm 2.5? I have the same problem. An older version of MP had a reset alt button that would fix it right up but newer versions do not or I simply can’t find it. When I start up apm and telem it shows zero alt on MP but the second it gets a gps fix then bam it tells me I’m 256 feet [ yea I’m a yank ha ] I see a setting to use the baro or the gps for alt. It’s set to baro. But still it tells me I’m at 256 feet or so. If you figure it out please post thx.

Nope, we’re using the APM 2.6. Bumping this up - does anyone have thoughts for how to increase the altitude beyond 1000M?


@bnzelener I hope that rapid desent didn`t end in a crash, that can be bad.

The only way to currently edit the altitude max value is by editing the source and recompiling it. But in the new version of droidplanner (v2) we changed to Relative altitude which should sove your problems. But there is another if as v2 doesn`t fully suport planes yet.

Hi Arthur,

The plane did crash, but luckily it was into a few inches of snow. It’s a foam plane, so it was ready to go again after a bit of gluing :slight_smile:

Do you know when V2 will support fixed-wing?


Waypoints heights are AGL, not ASL.

If you read back the Mission are they being set correctly?

[quote]Waypoints heights are AGL, not ASL.

If you read back the Mission are they being set correctly?[/quote]

When we set the waypoints in ‘APM Planner 2.0’ (the Mac OS X mission planning application) and then send them to the drone, we’re able to load the waypoints from the drone to DroidPlanner via the 3DR telemetry module and they seem to work fine. DroidPlanner follows the mission once we put the plane into auto, and announces “proceeding to waypoint X” at every step.

We haven’t tried doing another DroidPlanner-set route since that first crash. Craig, are you sure that waypoint altitudes are AGL? If so, maybe there was just a bug in our Ardupilot that day.


Tried again last weekened and the Bixler started losing altitude again, FAST.