AltHold mode running KDE


I am busy building a new X8 using KDE motors and their UAS55HVC ESCs. These ESCs does not normally require calibration but when using them with the Pixhawk it is recommended to buy the programming board and then set them to manual calibration. After this one can perform the normal “all-at-once” calibration.
I only realized this when I wanted to perform the ESC calibration during the setup phase. I immediately ordered the programming board but also read that some guys were flying these ESC without doing this step. So to save time while waiting for the board I continued and after finishing tried a quick take-off.

In my previous builds I normally made the first flight in AltHold mode but this time around there was no joy. Increasing the throttle almost to mid-stick still didn’t even start the motors, scared of having a sudden take-off I rather tried stabilize. Switching to Stabilize works fine, motors start spinning soon after increasing the throttle and then she lifts off.

So my obvious guess is that it has something to do with the ESC calibration that I need to perform. But I don’t want to wait until I receive the programming board just to realize that I didn’t need it after all.

From what I can see in the logs, RCIN.C3 clearly shows that the throttle is increased while in AltHold but CTUN.ThO shows that no throttle is given to the ESCs. I guess when in AltHold the throttle sets the desired altitude but for some reason the desired altitude is not set. Could this just be related to the ESC calibration and once done should be fine? Any advice for things I can check?



I believe with 3.4, there is now logic to suspend takeoff in Loiter and likely Alt-Hold until the throttle is beyond mid-position. Try increasing the throttle just beyond mid-position and see how it works.

That being said, I would recommend doing the all-at-once calibration with the KDE ESCs. We tried operating without doing that and were forced to use these settings:

I believe having the MOT_THST_HOVER value so close to the MOT_SPIN_MIN value created a problem on landing though where the motors wouldn’t disarm and sometimes it would spin back up to adjust attitude since it didn’t think it had landed yet.

3.4 also supports parameters MOT_PWM_MIN and MOT_PWM_MAX that allow you to remap the R/C output range (say 1100 to 1900) to the desired ESC input range (say 1000 to 2000). We didn’t get a chance to try it though. There is a discussion here:

Hi rrr6399,

Thanks, I was not aware of this (throttle above 50% for loiter/althold take-off). To understand why I made a quick search and found that you asked this very same question but without any answer. Would be good to know why… maybe based on the logic that above mid throttle the copter should climb…

Anyhow, the postal tracking number indicated I should receive the programmer tomorrow and will then switch to manual calibration. Nevertheless its interesting to know about the MOT_PWM_MIN and MOT_PWM_MAX parameters.

Just as an update for anyone who might do this in the future:

The programmer arrived and I updated my firmware to the latest version for all ESCs and set the “Throttle Calibration Mode” to Manual. Then performed the all-at-once calibration, made a few ground tests, put the props back and went flying. Works great!
I also followed rrr6399’s advice and just pushed my throttle over half while attempting an AltHold take-off and it also works great. Shortly after passing mid-throttle the copter gently takes off.
I would also recommend anyone using these ESCs to just buy the programmer (its cheap and looks basically just like a USB to Serial converter) and perform these steps. This way you can also make sure you are running the latest firmware. I received my ESC about a month ago and there were already 2 updates, so it seems the guys at KDE are releasing updates on a regular basis.