Alt-hold motor pulsing

When the rangefinder is enabled (Lightware SF11/C) I can hear the motors start pulsing at around 2 Hz (very pronounced sound) and the attitude stability ‘feels’ reduced.

It seems that the rangefinder makes this problem more pronounced, rather than being the root cause.

I have CH11 set to enable / disable rangefinder (high is enabled) and you can see the motor outputs oscillating when it’s enabled quite cleary:

Alt-hold seems overly aggressive to me and is not doing the system efficiency any favours.

(see below alt-hold vs stabilise)

I have reduced ACCEL_Z_P and ACCEL_Z_I by 50% (the mimimum Misson Planner allows) as recommended in the docs without much noticeable effect.

There is also ACCEL_Z_D (default 0) and ACCEL_Z_FILT (default 20)… which I’m tempted to change but I’m not sure of their effects.

Is there anything I can do to smooth this out?

Thanks in advance,

2017-06-24 13-41-06.bin (2.4 MB)

Where you plug it? I plugged in analog port and no problem , very stable.

Mine is on I2C… I saw your post, looks like a similar problem.

I previously had it on Serial, and the problem was the same.

I had a similar problem with alt-hold pulsing. But I am not using a rangefinder.
In my case it is due to INS_ACCEL_FILTER being reduced from 20hz to 10hz. Increasing it back to 20 fixed it. Before someone told me to check that filter setting, reducing the throttle P and I, also fixed it.

I remember I initially had this problem on AC3.4.6 but setting throttle accel P and I to 0.5 and 1 respectively seemed to fix the problem.

I can see that INS_ACCEL_FILTER has changed to 10Hz since upgrading to AC3.5, but I’m puzzled as the PR for this change implies it will smooth out the response…

I’ll try changing the setting back to 20Hz tomorrow and see if it helps the issue.

@wicked1 you’re right. I’ve just done a very quick test with INS_ACCEL_FILTER set to 20Hz and the oscillations are not audible anymore, (but seem to still be happening.)

20 Hz


Even at 20Hz this doesn’t seem normal to me though.

Surely this should be filtered further as these sudden throttle changes aren’t going to help much with maintaning altitude but will certainly waste power…


I noticed the same… The pulses were much better, but still slightly there.
I don’t know exactly how well tuned this copter was before upgrading to 3.5, so maybe I always had the minor pulses, but didn’t notice? I’m not sure.
If I have time today or tomorrow, I’ll leave the filter at 20hz, and try lowering the throttle P and I slightly… not all the way down to .5 and 1, but something less than .75 and 1.5…
I was assuming the issue is because I have a small overpowered copter, as does someone else who noticed a similar problem.
But I’m guessing your copter is a more standard larger copter, if you’ve got a rangefinder…

@wicked1 My copter is quite big (10Kg X8) but like yours is quite overpowered. (CTUN.ThH=0.17), so maybe power is a factor (rather than size)?

I’ve just looked at some old logs from when this X8 was running AC3.4 and the graphs look the same (lots of oscillation on CTUN.ThO)…

but here is a log from my F450 clone quad… really smooth output in comparison.

I my case 20 was not sufficient, set it to 30 solved the problem.

What size and power is your copter?
My mid throttle(CTUN.Thr) is about the same as Juzzle1. 0.18.

I wonder what’s better to change? Increasing the INS_ACCEL_FILTER, or lowering Throttle P and I?
I need to test a few things, but still haven’t had time… Hopefully later before it’s dark…

Its 650 size, Tarot foldable frame-based quad-copter, powered by DJI E320 “Tuned Propulsion System” motors and ESC’s, 4S 10K Multistar Battery, dead-weight is 2.4 kg.

I did have time to work w/ my copter yesterday, and I basically had to re-tune everything, compared to before I loaded 3.5.
Accel filter at 10hz caused noticeable alt_hold oscillations.
Increasing it back to 20hz made them much less noticeable, but they were there… And quickly flicking the controller sticks would sometimes induce oscillations, that would eventually settle themselves.
Increasing it to 30hz caused oscillations in all modes. Not just alt_hold.

So, I put the filter back to 20hz, and manually tuned the copter for a while, and it’s flying well again. I had to tune everything, though… all my PID’s and throttle and loiter all required tuning.

Is this something the devs should be concerned with? Or at least make note of for others to be aware that updating could require a new tune? There are definitely a bunch of us having trouble w/ this filter setting or something else that has changed w/ 3.5.

I posted about this ~10 days ago (and the reply to you wicked1) but it didn’t get any attention so I assumed it was an isolated case. Or it’s because my PixRacer is on a very compliant mount. Setting the Accel filter back to 20hz fixed this for me with no other tuning changes but I must be missing something about this parameter. If this is the filter cut-off frequency I don’t understand how a lower value can cause this.

HI All,

Randy and I have been looking at this. We have known for a long time that the default Alt Hold PID’s are a little too close to oscillation and that powerful copters need to have the pids dropped. When I dropped the filter frequency I underestimated the number of people that this would push over the edge.

We will increase the default back up to 20 Hz for this release and delay the change to the next release where we will also do some rework on the Alt Hold controllers and add Alt Hold to AutoTune.

Thanks for all the feedback. The beta testers have always been a critically important aspect of this project!!

Thank you!