Servers by jDrones

Almost following waypoints - not quite there yet - reaching out for help


(jeffg) #21

Grant,

Wow. Thanks so much ! If we ever meet, beer is on me.

Now, I have a bunch of things to check for tomorrow.

I do know:


(jeffg) #22
I can see you have RC1 reversed - steering. You just have 1 rudder on this boat right? When in Manual mode do you have the steering stick (whichever is mapped to channel 1) reversed? If so your setting is correct. If not your setting isn't correct and needs to be changed. Think of it like this - when your in Manual mode ArduPilot isn't involved. Every input you make simply goes straight through to the motor and rudder. When you steer left if you notice the rudder goes the wrong way then you reverse it on your transmitter right. Now, when your in AUTO mode your transmitter isn't involved. But ArduPilot also needs to know that the rudder is reversed so you need to make the channel reverse setting in ArduPilot. Make sense? 

jg: Yes - it does. thanks for explaining it. Will check again tomorrow.

Your RC3_DZ is 0. This isn’t a good idea - best to leave it at 30. The ardupilot uses this value to know when the throttle is “neutral”. Without it ardupilot might continually move the throttle to try and hit that 0 number.
jg: good catch - will correct.

Your RC3_TRIM is 1556 - that’s a little high but no biggie.
jg: will adjust anyway.

LOG_BITMASK is 3950. That’s not a log of logging and is going to affect our ability to diagnose the issue. Any reason you don’t leave it at the default of 65535 so we get everything logged?
jg: will do.

Your FS_THR_VALUE is 1100 whilst your RC3_MIN is 1106. That’s a little too close I reckon. You should be able to drop FS_THR_VALUE down to 1000. Note you don’t have the FS_THR_ENABLE set so its not being used - just thought I should mention it whilst I saw it.
CRUISE_THROTTLE is 52% and CRUISE_SPEED is 1. This is telling ArduPilot that you need 50% throttle to do 1m/s. Is that correct? Try out in manual mode and see how much throttle you need to do 1m/s and then set CRUISE_THROTTLE accordingly. This setting helps ArduPIlot do the math better. Not it won’t affect navigation.
jg: will work through the process.

Your BATT_CAPACITY is 33020000. That is a very big number. Is it correct?
jg: Correct. The entire keel is filled with SLA batteries. It should run for about 10 hours on a single charge.

Your ARMING_CHECK is checking for GPS_configuration, LoggingAvailable, RC Failsafe, GPS Lock and Compass.
And your ARMING_REQUIRE is set to 0 meaning it will boot and ARM (you have no safety button I see) regardless of what the checks say.
jg: Had a bad experience with arming and running amok. So, i set up one of the radio switches to control power to motor and servo. It really helps to be able to remotely cut the power to everything when you are testing in a harbor.

Thanks again for going through the logs and taking the time to write things out!

jeff


(jeffg) #23

Changed RC1 so that it was all set for one direction (radio, pix and servo)
changed RC3_DZ to 30
corrected trim by adjusting the hardware
changed bitmask to get more log data
Determined that throttle at 15% = 1 m/s and made the correction
Left Arming disabled
Rotated the Pixhawk so that it was facing forward and set the compass to do the same and then reset the orientation to 0.
Did some other clean-up with the servo mechanics, and the over-all wiring. Had to replace power wires because the salt water is so corrosive.

And IT WORKS !!!

Wohoo - Yippeee – Horray… Time to re-enable sonar and fiddle with the settings to get a cleaner mission path.

Thanks again …!

jeff


(gmorph) #24

Delighted to hear you got it all working. Well done. Pictures and videos are always welcome :slight_smile:

Thanks, Grant.