Almost fly away

i had a very unsettling flight yesterday that I cant seem to wrap my head around. I have been flying during lunchtime at work and usually get 2 good flights in. I flew the fist flight with no issues. In fact, it was a picture perfect flight.

Second flight, it plugged in a battery and noticed that the telemetry seemed a little off. the battery voltage was reading low and the horizon was not showing level. I have noticed this happens sometimes where droid planner and the quad somehow get out of sync on a battery change. I pulled the battery, disconnected the droid planner app, plugged in again, connected and then everything looked ok.

My normal MO is to take off, climb to about 10ft, engage loiter and make sure everything looks kosher before trying any real flight. I did the same thing here, but it started drifting backwards in loiter. After a few seconds, i switched back to stabilize and started giving forward stick… almost no effect… Full forward stick and I am still drifting backwards, over my head and over the treeline! Uh oh… Switch to RTL… still drifting away from me… after a few seconds of that, switch back to stabilize and finally after giving it full throttle, I manage to coerce it back over the field, but I still have VERY limited control. I finally managed to get it down, but its a very hard landing (which it seemed to survive amazingly well).

After looking at the logs, it looks to me that after takeoff, the Artificial horizon is showing an erroneous nose down attitude, when in reality it is slightly nose up and drifting backwards. I cant figure out why, especially when I just had a perfect flight 5 minutes before.

Can someone help analyze my log files and help me figure out what happened? I obviously dont want a repeat of that…

After fixing the cracks in the body (there were a few…) and replacing the GPS (apparently the shield had a dent in it from the crash and it would no longer acquire satellites) I just took it out to fly again… Once again, it flew perfectly and all telemetry looked great!

It is a little unnerving that I still cant account for the odd behavior.

your compass offsets are pretty high, it may be it.
If your compass is bad, you’ll see it fly a long curve or toilet bowl - depending on the error and your heading.
Try to fly at least 3km/h in one direction, then switch on loiter and release roll/pitch stick - it should “break” and stop - then keep position, then yaw until you head in another direction, and retry.
The stable stop from speed should work equally fine regardless of heading. - I guess yours don’t.

It has never had an issue with heading hold. Again, the really strange thing was that flight was totally crappy from the start. The flight before that was flawless and the test flight I did right after that was nice and stable. You can stick it in loiter, put down the transmitter and it will sit there as pretty as you please.

Just out of curiosity, which parameter are you looking at and what should the value be?

You meant loiter ? - or pos.hold ? (when you wrote heading hold)
I was looking at Compass_ofs_x ,y,z. who of yours are high, but it does not mean this must be the problem.
Anyway, if it flies fine in stabilize, but does not hold position with good GPS reception, magnetormeter is usually the thing to look at.

I meant it would hold its position within a few inches when in loiter mode…

On that particular flight, neither stabilize or loiter or RTL modes worked… That is the bizarre part… they worked great one flight before and one flight after.

The heading saved n the logs is consistent with the actual heading I remember, so I dont think its a magnetometer issue. The thing just seemed to think it was nose down when it was not…

what are typical values for the compass offsets?

Your magnetic field is just completely off the chart during the flight:

Look at this article for details on how it should look like: … terference

Were you flying with a GoPro attached? Was the Wifi on by any chance?
Anything else that could have messed with the magnetic field?

the gopro was on, but WIFI was turned off… there is also a 5.8Ghz video tx attached…

you know, that big spike before I took off was probably me turning on the GoPro… Have you had issues with the GoPro causing interference like that?

I did a little flight testing today… Since we are going down the path of having a magnetic interference issue with the video equipment, I decided to do some flight testing with the equipment mounted, but in various states of disconnection. With the same battery pack, I took off, climbed to about 10 feet, did 2 complete turns in place, and then landed again. I did this:

  1. With nothing connected
  2. With just the video Tx connected (immersion RC 600mw 5.8Ghz)
  3. With the video Tx powering the GoPro via USB port (no battery inside)
  4. With the video TX unpowered and GoPro powered by battery only.

I think the spike you see when the video TX was plugged in is really from me turning the Quad upside down on my car’s roof to access the conenctor. When flying though you can clearly see the mag field is not as clean.

It actually looks ok with just the GoPro on the front by itself running on the battery…

Currently the video Tx is located inside the shell quite close to the APM, so it is not totally surprising that it would cause an issue, although the antenna is at least 3 inches above it. I guess I need to move this…

I am still not convinced this was the issue I was having on my crash flight though, although it is a good experiment and taught me a lot.

I was actually about to recommend you running through these tests. Good job!

Yes, placing IRIS on a big metal object like your car will cause the compass interference you have seen. :slight_smile:

With regards to your previous question: I have read about folks about having issues with their IRIS and fly-aways when the GoPro had Wifi on. There is also a video on Youtube from such a fly-away. The frequency of the GoPro Wifi is the same as the one for the RC transmitter.
Therefore if you would be hitting this issue, you would see crazy stuff on the RC IN channels. I can’t see anything out of the ordinary here.

To me it still looks like your issue was cause by magnetic interference on the compass. If you read the link that I posted before it says: "Below 30% inteference is acceptable. Between 30% ~ 60% is in the grey zone where it might be ok (some users are ok, some are not) and really bad magnetic interference will show up as jumps of over 60% when the throttle is raised."
It looks like you are within the grey area most of the time when flying with video TX on and might have just hit an unlucky day.
Without any GoPro on and with just the GoPro mounted on the front the interference looks acceptable.

More food for thoughts: The uBlox unit is mounted to the top of the hull with metallic screws. They could act as an antenna with a video TX transmitter present close by. It might be an idea to replace these screws against plastic ones. No guarantees that this is really a problem. But just an idea to be on the safe side.

Few questions on the Video TX, partially to see how it could have caused your crash, but partially cause I want to fly FPV myself with IRIS some day. :slight_smile:

  • How do you power it?
  • How do you have the antenna placed?
  • Do you use an OSD?

Any picture of your setup (especially how it looks like under the hull)?

Here are a few pictures of my setup. Since the crash, I haven’t mounted the board camera again. Today’s testing was done just with the GoPro and the gopro was also powered by the video Tx (it has a filtered 5V output)

the video transmitter is mounted with foam tape to the shell and the antenna comes out the back opposite the 915mhz antenna. I have the power for the video Tx plugged into the power lead that the gimbal would use (which is tapped directly off the battery leads).

I love the look of everything inside the shell, but that also means close proximity to all the sensitive things. Maybe I should mount it below somehow…

The fly always from the GoPro Wifi were probably from a RC lockout. I noticed that mine didnt have the failsafe set from the factory. Without the failsafe set, the receiver will just output the last PPM signal it received… I was able to reset mine so that it will RTL on signal loss, which actually seems to work well… That is always a little unnerving the first time you test it, but there is nothing quite as cool as turning off your transmitter and watching your quad turn around, come home and land all by itself! :slight_smile:

[quote=“kangajump”]With regards to your previous question: I have read about folks about having issues with their IRIS and fly-aways when the GoPro had Wifi on. There is also a video on Youtube from such a fly-away. The frequency of the GoPro Wifi is the same as the one for the RC transmitter.
Therefore if you would be hitting this issue, you would see crazy stuff on the RC IN channels. I can’t see anything out of the ordinary here. [/quote]
What about if we fly it using auto mode and 915MHz ground control for TX/RX… no 2.4GHz RC involved… Does GoPro still interfere (electro-noise)??

A nearby GoPro is jamming the GPS even without WiFi turned on. At least my Silver does. As well, it is not a good idea, to place a FPV cam just in front top of the GPS, shading it and most probably causing extra interference. Same goes for the FPV transmitter / antenna… (VTx)

I would check possible interference sources before final mounting , using ublox u-center (connecting the GPS with an FTDi adapter), which allows to see whats happening with GPS reception, when add ons are turned on.

Btw. : This is not an IRIS / PIXHAWK specific topic. I am sure that careless add on mounting (FPV, Cams) is responsible for a lot of fly aways, regardless of brand…

But I am sure, that 3DR will present some “RF wise safe installation” guidelines for the IRIS sooner or later.

I decided to make an FPV pod. I recently recieved my gimbal, so the GoPro mount was not being used… why not put the FPV components up front so they are away from the GPS and PixHawk?

Preliminary testing looks good. Now I just need a wind free day to really test them. My quad experience is still not that great. I have been flying fixed wing for decades now, but this is my first serious heli…

I had a strange happening a little while ago and not sure how to tell what caused it. How do I bring up the logs so I can see if there is anything strange. Also as you answer that question, what is the best software to use with the Iris. I have been using mission planner but if I should be using something else please share your thoughts.

Here is what happened to me. I was getting ready to take my Iris out for the second time. I just installed the Gimbal and made sure all the setting were ok. I also installed my Fatshark FPV transmitter just behind the gimbal it is the 250mw and the antenna is to the back right looking from the front and pointing towards the ground.

I took off is STB and went up about 30 ft. I then switched between Loiter and alt hold but was having a problem getting control. My Iris started drifting away and I could not get it to come back. I put on my goggles so I could see which way it was facing and tried to regain control. Still drifting I started to panic some as I could not see my iris very well. Goggles still looking good, but very little control. I am guessing I am maybe 500 ft or so away and my radio starts beeping. I don’t know what that meant so some help here would be great. The voltage of the radio was still near 12v but it did not stop beeping. So in a panic I switched to RTL and I could see my Iris turning back !!! what a sigh of relief. I let it come almost all the way back and then switched to STB and brought it down for a good landing. It seemed to be responding this time, but I left it in STB just to be safe.

I was hoping the logs may tell something, but I am new at that, so help would be great. I am a bit nervous to fly it again till I have a better backup plan. Oh, the GPS HDOP was very good and there was very little wind.

Let me ask this, being connected by telemetry could I have brought it back that way if the RTL did not work? and how far will the telemetry go? And still wondering about the beeping, did I loose a connection to the Iris? I was not that far away and there was no interference from the surrounding area as I was over a farmers field.


Grandpa Jake

mission planner is still the most featured of the ground station software packages I have seen so far. Droid planner is another one, but it is still missing some of the features that MP has. Its very convenient though because of the portability of the android devices you can use it with.

Both will save log files when they are connected to your quad. There is a LOT of information in these logs that are useful. details on these logs can be found here: … etry-logs/

if more details is needed, the copter will also save logs internally every time it is powered on. These have more details about the hardware and can be configured to save a lot of very details data. These can be downlaoded using mission planner and the USB cable that came with your kit. Details here: … n-planner/

As far as getting it home, In my opinion you are never better off than when you have the transmitter in your hand. RTL is the same if you do it with a switch or if you do it with the mission planner. If you have marginal control, you can still roughhouse it home if you have to, whereas the automatic modes might not understand the issue well enough to compensate (which is the problem I had… i hit RTL to hopefully let it take over and it just kept getting farther away…)

Thanks, has to be one of the scariest moments !!! I still don’t know why my Radio was beeping, but maybe the logs will tell more. I am going to try and read up on that so I have a better understanding. I am also going to program some of the failsafe’s in just to be safe. I was so happy when it did turn back and was just hoping I could get control which I did.

I tried to position my FPV as far away as I could from everything else and I never turn on the Wifi from the Gopro. I hope this does not keep happening as I had bought the Iris so I could take some nice video and loosing that much money would not be good.

I found my logs I will upload the one where it happened so if anyone can check it out and notice anything please let me know. Ps. does anyone know why my Radio would start beeping?


What did you find in regards to the Beeping? I had the same thing happen, but saw nothing on the controller showing what it might be. Also have you found out if your FPV was the cause for the problems? I would like to put a fatshark 5.8ghz FPV on mine, but don’t want any problems.

Take care

the beeping is the transmitter telling you that it is losing its connection with the receiver, either due to interference or range. I notice mine will do the same when i start flying further away. If it start beeping, you can raise the Tx and make sure the whip antenna has a good LOS to the quad and it will stop.

Of course, it is very critical that you set the failsafe on the Rx… Mine was not set from the factory. Now I can completely turn off the tx and the quad will just RTL…