Airspeed Sensor Scales With Increase In Throttle While NOT Moving [SOLVED]

I have a Loong 2160 that I have built up with my chosen components. This is a VTOL configured in 4+1. This is NOT a kit from Foxtech, I just bought the airframe and chose all other components.

Loong 2160 Param 1.0.param (21.5 KB)


  1. Cube Orange, v4.1.6 is installed.
  2. No vibe errors
  3. No EKF errors
  4. GPS is locked in at 12 satellites indoors and I can typically can get 18 with it outdoors.
  5. Most parameters have their initial values but not all of them yet.
  6. The Static port is an allen screw with one tiny hole in it (designed for pressure relief applications) that is screwed into the same style of 4mm tubing supplied by Drotek and goes directly into the SPD3x sensor. That section of tubing is glued in place and is tucked away in the fuselage. It does have access to the air pocket in this loosely sealed up fuselage belly.
  7. The dynamic port is strung about 3 feet out into the wing via a 1/4" wide semi-rigid clear plastic tube and connects to a brass airport that is screwed into wing root (plastic part of the wing root). From there there is a sleeve (made of fuel tubing, blue from great planes) that slides over it to bridge it to the second brass airport which is also screwed into the fuselage’s plastic wing root. On the inside of the fuselage the tubing (the 4mm wide typical tubing supplied by Drotek that you can see in the airspeed sensor pic on their website) connects to that brass airport and goes directly to the SDP3x sensor.


I have installed a SPD3x airspeed sensor made by Drotek. I have used this sensor for at least 3 years now and with one bad wire job on my part it has been a very very good airspeed sensor.

Since I am nearing the end of build I have started motor testing. While having the bird strapped down to a test table I slowly ratcheted up the throttle to 30%. The motor works fine, the throttle ESC is calibrated etc. All looked great until I looked at the reported airspeed.

The airspeed was saying 8mph when it should be reading 0 or 1mph. This sensor is THAT accurate. If there is zero wind the airspeed is reported as ZERO (unlike the analog and digital ones that typically are used which can report up to 13mph with zero wind). This airspeed sensor was made for VTOL applications.

  1. If I throttle up the airspeed goes up, if I throttle down the airspeed goes down.
  2. If I have 30% throttle and it is reporting 7-9mph and I put my finger over the dynamic port that is embedded far out on the right wing the airspeed goes to ZERO.
  3. At 100% throttle the airspeed is reported as 22mph. The static thrust of the motor at 100% is around 6.3kg (14.52 pounds of thrust).

Short video of the problem here.


  1. The airspeed calibration variable ARSPD_RATIO is set at 1.99. This was changed to 3.969 (the value my last SDP3x sensor calibrated at) and this problem still exists.
  2. During motor testing all of the moving air is a good 2 feet away from the external dynamic port (the pitot tube). No moving air is present at the entrance to the dynamic part of my pitot tube.
  3. If I block the crack in the wing root (about 1-2mm wide crack) with my hand during 30% throttle nothing changes so I do not think it is a problem with the bridge tubing between the two brass airports.
  4. If I blow into the dynamic port the response is as expected which is a reported increase in airspeed.
  5. UPDATE: I unbundled the 3SDPx I2C wires from the rest to ensure there is no cross talk (induced voltage) and re-ran the test, no changes, same symptoms
  6. UPDATE: I visually inspected the tubing for debris, none found.
  7. UPDATE: I ran ONLY the VTOL motors and even at 60% throttle there was NO effect on airspeed, so this has something to do with the Forward motor/throttle signal being used (mode was manual for forward motor runs and QLoiter for VTOL spin up tests).
  8. UPDATE: Covered the dynamic port with tape for manual forward motor spin up and to my surprise the increase in airspeed DID occur when before this it did NOT occur. I have no idea why.
  9. UPDATE: Shown below in a pic I attached some spare tubing between the wing and fuselage and SECURELY fitted them over the brass air ports. I could hold the wind up by the tubing and shake it without the tubing coming off so yeah, it’s a good seal. I turned the motor on and sure enough, same problem! So now its either the position of the static port OR I have the dynamic and static ports reversed at the sensor itself.
  10. UPDATED: I did have the dynamic and static ports reversed according to this drawing:

    IF the high is dynamic and the low is the static then I did have them reversed. I adjusted the tubing and retested to see if this was the problem. NO change occurred.
  11. SOLVED: I then hooked up a pitot tube with a built in static tube such I have always done. The systems works as intended. Whatever this problem was, it has to do with having a separate static port. I’m done trying to figure this out so instead I will find a way to revert the airframe into accepting a “standard” pitot tube system. How disappointing.


  1. It will not currently arm when using right rudder arming maneuver. No errors as to why are generated. Transmitter re-calibration did not change this problem. Settings are:


  1. *Wiring is tight and bundled, could this be cross talk between wires? If so then why would the airspeed go to zero if I plug up the dynamic port while the motor has power? tested as not relevant to this problem as described in #5 above.

Pics (because it DID happen…)

The hairs are NOT in the tubing, they were caught in the hot glue.

Experiment to prove where the air leak might be.

Several boot sequence messages shown above just in case this helps.

Anyone have any idea what this could be?

CONCLUSION: After many tests I think I might know what is happening. The tubing and brass connectors in the left wing (pitot tube dynamic’s location) is just fine and has no leaks. The brass connector and “bridging” tubing connect just fine and also has no leaks. There are also no leaks in the tubing that goes from the inside of the fuselage’s brass connector to the SDP3x, it’s all airtight and good despite having that weak point of a 12mm long “bridge” tube that goes from the fuselage to the wing. The problem is that the fuselage is NOT airtight. The hatches do allow air to move into and out of the fuselage but only a tiny bit. When you run up the motor with a prop attached this causes rapid air movement over these hatches and thus over the tiny cracks between the hatches and the fuselage body. This is text book vacuum creation. So as the air pressure DROPS inside the fuselage the static port (which is embedded in the fuselage wall) sees the slight pressure drop. This creates a difference between the pressure at the dynamic port (located far away from the prop’s moving air so it’s at normal pressure) and the static port (which feels some vacuum pressure) and it then gets reported as an increase airspeed.

If this is not whats going on then I don’t know. Either way, I’m converting the airframe to handle a combined static and dynamic airspeed sensor.

Rudder arming: Assuming that the parameters are correct for rudder arming, and you aren’t failing any pre-arm checks, then I would say that you should try to re-calibrate your radio settings in mission planner. Make sure your radio doesn’t have any dual-rate settings that are limiting the full throw of the rudder output.

Airspeed: Those sensors are just pressure differential sensors between the static port and pitot tube (dynamic port). All airspeed sensors work that way. So if your getting the speed increase with throttle then look for some kind of air leak that is letting the air pressure change around the static port. I’m not familiar with your exact sensor, but often the static air is taken from static ports located on the pitot tube. Or maybe when you run the motor something is flexing causing the line to the pressure side to get pinched. If your running the motor with the centre panel removed there might be a pressure drop from the air movement over the fuselage.

Maybe for a test, try running the motor without a prop. If the problem is still there, then it’s electrical.

Very good idea!

I put it in manual mode and removed the prop. Spun the motor up to 70% with NO effect on airspeed so yes, there is a problem with the airspeed system it’s just not electrical or firmware/software related.

TYVM! That helps a lot!

As for the ARM/DISARM I re-calibrated my transmitter and still no joy there. My Arming settings are: