AirSpeed (ms4525do) Sensor Data is not reading from GCS

Hi guys, I have an issue with air speed sensor, I read the documentation about the calibration, but in the fist , before the calibration, I don’t have any readings coming from MS4525DO, then I try to calibrate result is same.
I connect TELEM4/I2C port and I2Ca in HolyBro Durandal, but I cannot read any data. It show me always 0.0 m/s.
And ofcourse I read all the topics that opened here, but my problem was not solved that’s why I opened that issue.
here is my parameters:

ARSPD_AUTOCAL,0
ARSPD_BUS,1
ARSPD_FBW_MAX,25
ARSPD_FBW_MIN,5
ARSPD_OFFSET,0
ARSPD_OPTIONS,0
ARSPD_PIN,65
ARSPD_PRIMARY,0
ARSPD_PSI_RANGE,1
ARSPD_RATIO,1.9936
ARSPD_SKIP_CAL,0
ARSPD_TUBE_ORDER,0
ARSPD_TYPE,1
ARSPD_USE,1
ARSPD_WIND_MAX,8
ARSPD_WIND_WARN,0
ARSPD2_TYPE,0

Mission Planner shows me that issue when I try to calibrate:

I did this calibration in different flight modes also, and I changed many times parameters with different value, didn’t work.
Thanks in advance, I am new here.

I don’t know if this applies to your FC, but some boards don’t power the external ports when running of USB. Try powering the board with a battery.

ASPD_FBW_MIN, 5 looks pretty low for a plane with a top speed of 25. Are you sure about that number? If you set that value too low it could force the plane into a stall.

I didn’t adjust velocity parameters yet, because I didn’t see anyy value coming from sensor, if I can I will deal with these values… Thanks for the tip, I will try it right now.

[RE]
I did what you said, but nothing change?
Is there any developer here to explain this error?


In durandal doc. page there is a paranthesis about pullup, I don’t know how to deal with that info, I open SERIAL5 port to use sensor as external, 34 mode (airspeed also tried 1 and 2 mavlinks) . Nothing changed in the o/p.

The original settings you described were for the I2C port. Serial 5 (or Serial 4 if you’re using the the Serial/IC2 port) should have nothing to do with it.

These sensors are pretty straight forward on I2C connections. How have you got it wired? Can you show some photos?

I set the parameters for serial 4 and 5 in different time, their mode was both mavlink and airspeed but nothing changed and my sensor’s SDA and SCL voltage level is showing me 0.16V when I measure it with straight multimeter, and its VCC and GND is ok.
Here is my connection ( GND-GND, VCC-VCC,SDA-SDA,SCL-SCL)
Because of GPS module mounted on controller, you won’t see I2C port labelled on it.



The problem could be the breadboard. Solder the wires one by one and test it.