Airspeed Changing drastically after each turn

I have been using my VTOL quite successfully for a few years but I am having a weird issue cropping up with my VTOL over speeding. It uses a pixhawk Cube black and these issues originally started when I upgraded to plane 4.2. I normally do mapping flights (straight lanes with 180 degree turns. After upgrading to plane 4.2 I discovered the plane would fly at normal cruising speeds into a small headwind one direction but then as it turned and reversed directions with a tailwind it would over speed by an additional 14m/s to 17m/s (flying at speeds up to 40m/s over my max limits). Mission planner would then complain “unhealthy airspeed”. I usually set my missions to fly at a speed of 21 m/s. At first I thought it was wind pushing the plane hard, but then it did the exact same thing on the next flight. So then I swapped my airspeed sensor out. That had no effect. I tried a few more times altering some parameters with no luck. So today I tried it in the mildest winds possible for my area which was about 5 m/s winds. It did the exact same thing, flying into headwinds it would travel at my cruising speed of 21m/s but as it turned into the opposite direction having a 5m/s tail wind it immediately sped up with an insane target speed of 40m/s with “unhealthy airspeed” popping up. As it would reach the end of the lane and turn back into the headwind the target speed would settle back down to where it was supposed to be and it would cruise normally at 21m/s. Examining my previous flight logs from after the upgrade to 4.2, I noticed that every time as soon as it turned out of the headwind into a tailwind it would attempt to reach a target speed of 40m/s no matter the amount of tailwind. What could I possibly be doing wrong? I noticed that Ctun.As and Ctun.SAs do not match. I have my trim_airspd_cmd set to 2600 so I know that is a bit high but it has always worked before. I zipped my bin filed and uploaded it to my google drive which you can download here. I also stuck my plane params in there just in case it was needed.
https://drive.google.com/drive/folders/1WEP2A6CG0ON65HVA8xNaa4AFB5iAS-IT?usp=sharing
I am sorry for the size I don’t know how to trim it.