Airplane wont AutoTakeOff - "Bad launch AUTO"

Hello friends,
I need your help since I am lost here and I ran out of ideas.

I built a new airplane with Pixhawk 1 with 3.7.1 arduplane firmware.
The first flight was good, performed autotune without problem, landed and prepared for next flight where I used the “AutoTakeOff” feature with pitch 12° and altitude 80 meters which was performed very good.
I use this feature quite a lot since it helps to perform safer take off.

Next day I wanted to do a new test, set the “AutoTakeOff” at Mission Planner, changed the Flight Mode to “Auto” to let the AutoTakeOff start but never happened. I keep receiving “Bad launch AUTO” at Mission Planner every time I changed to Auto mode. Also got a “Timer interrupted AUTO” message.
I tried like 20 times, power cycling the airplane, connecting everything again and nothing. 1 week later I also tried to take off without any success and I kept getting the same “Bad launch AUTO” and “Timer interrupted AUTO” errors.
Every time I tested I got good GPS fix and no other errors than those mentioned.

I looked through every forum without success in which is the cause of those errors.

Can you help me? Did anyone got the same problem? What suggestion do you have?

I attach one log file of the “flight” so you can check it since I dont know how to look for errors on the log files.


I took a look at your log, and I don’t see any obvious problems with your AutoTakeoff setup. That could mean there’s a bug, or there could be something I missed. Can someone else take a look?

Is it possible to update to the latest firmware version and see if the problem persists? If it’s a bug, that might fix it.

Another idea: Do you have multiple “takeoff” commands in your mission? This shouldn’t affect things, but just to be sure, make your mission as simple as possible and see if the takeoff begins working correctly?

[Details of what I found]
In case it helps someone else to figure out the issue, here’s some stuff I found. In takeoff.cpp, I find the lines
// this is a more advanced check that relies on TECS
uint32_t now = millis();
uint16_t wait_time_ms = MIN(uint16_t(g.takeoff_throttle_delay)*100,12700);

// Reset states if process has been interrupted
if (takeoff_state.last_check_ms && (now - takeoff_state.last_check_ms) > 200) {
    gcs_send_text_fmt(MAV_SEVERITY_WARNING, "Timer interrupted AUTO");
    takeoff_state.launchTimerStarted = false;
    takeoff_state.last_tkoff_arm_time = 0;
    takeoff_state.last_check_ms = now;
    return false;

takeoff_state.last_check_ms = now;

The key statement I noticed that causes the “Timer interrupted AUTO” message seems to happen if you wait longer than 200 ms between calls to auto_takeoff_check (called from Attitude.cpp). If you know how to compile firmware yourself, you could increase this “200” number to something higher and see if that permits takeoff?

Any time you leave an auto takeoff to another flight mode (IE manual) the timer stops checking. That message will only fire if the autopilot was part way through a takeoff command when you swapped modes, then when you come back. All it really means is the auto takeoff is being restarted for you. It’s a really silly message, you can safely ignore the “Timer interrupted AUTO”.

@hunt0r the message is not sent in the 3.8 release onwards

I don’t see any “Bad launch AUTO” warnings in this log, these are related to if the plane is rolled over to far, or pitched to nose up/down.

Thank you very much hunt0r for your time to review the log and reply.

I recently uploaded the same firmware to the pixhawk (version 3.7.1) and reset to factory all the parameters. Then I uploaded the last working parameters again. I doesnt make any sense to do this but since I dont know what is the cause, maybe this works (like magic).

I dont want to upgrade the firmware to the latest (3.8.0) since I read the migration process is somehow “difficult” ( and I dont want to mess up the parameters. Also, I read the section of “tuning parameters” and it seems that I will need to re do the autotune process.

Also, I dont have to much experience in editing the ardupilot or compile to a new firmware. I am a begginer user. I dont know about the TECS you mentioned. Sorry about that.

Thank you very much again. I almost did like 20 auto take off with this controller, i dont know why it doesnt work now.

Thank you WickedShell.
I tried multiple times to auto take off doing some power cycling, maybe the log that I uploaded doesnt have that error but happened later in other tries (without sucess).
The problem is that the motor doesnt start. It is configured to start the motor as soon as I switch to AUTO, it doesnt have any triggers like acceleration or timer or groundspeed. When I switch to Manual and then tu Auto I get that “Timer interrupted”.
Thank you again.

In the log you uploaded, TKOFF_THR_DELAY is set to 2… was that a mistake?


After lots of testing of trial and errorI found the problem and now it works. The problem was that I made a recently RC calibration, when I calibrated all channels I forgot to turn off the safety throttle switch which keeps the motor to 0% independent from the position of the throttle position. The RC calibration for channel 3, the throttle, was always to the minimun of 1080 pulse so for the auto or FBW mode the motors was always turned off because the maximun RC for channel 3 was 1080 or 0%.

1 Like