Airmode issues in QuadPlane

Hi all. After much experimenting setting airmode to a switch I can only get Airmode working in QStabalize mode but not in QLoiter. Simply changing to the QLoiter stops airmode from working.

I also cannot get Airmode to work via arming switch on any Q flight mode at all. I’ve noticed in Q_Options there is no box to select the airmode function and when typing in bit 9 it ticks two other boxes not applicable. Is this possibly a little used feature that is a bug?

So further testing I realise that I should be typing 512 into the Q_Options parameter to select the Airmode function when arming on a switch but as above I can only enable airmode in QStabalise mode and not QLoiter.

Airmode is a feature of QSTABILIZE and QACRO only. You won’t be able to use it in QLOITER, or any other flight mode for that matter.
Check out the documentation of Airmode to learn more about this.