Air speed TOO FAST. Target 10m/s, actual 18+ m/s

Hi All,
I recently upgraded to an air speed sensor for a wing wing z84. Plane flies create in FBWA and AUTO but it does not seem to control air speed very well. Cruise speed is 10m/s but its flying at least 20m/s. Altitude control seems fine. Wind was slight. I did the preflight calibration was reading 1-2m/s airspeed on ground.

How do I tune the TECS control for better control of the airspeed of the plane. I think it could be the TECS_SPDWEIGHT parameter but im not sure exactly how to change it. 25% throttle gets about 10m/s but in AUTO its sitting up at around 45-50% and hence why it is so fast. I’ve tuned FBWA so the max and min climb/dec work well with max/min pitch.

Could someone shed some light on tuning of this and how to reduce the airspeed? Even a simple starting point will help me on how to reduce the air speed in AUTO.

Thank you.

What’s your THR_MIN set to? Also what is TRIM_THROTTLE set to? It’s possible the plane is overpowered if it’s getting 10m/s at 25% throttle and thus can’t lower the throttle enough?

10m/s is quite slow for many fixed wing planes. As stated, the planes power setup may be too fast for that. Or did you calibrate the airspeed sensor? Uncalibrated airspeed sensor can report incorrect readings.

Is the rubber tubes bent at all restricting airflow? Is there wind? you can easily have 5-10m/s winds at higher altitudes that you don’t feel on the ground.

Hey guys,

Thanks for your replies. My min throttle is set at 0. My trim throttle is set at 35%. I thought with a air speed sensor the trim throttle is used initially and then airspeed sensor used. I changed trim throttle to 25% and the throttle average % did move down a bit from 50% to 40%. Air speed was still at the 16-17m/s. Maybe ill try trim throttle at 15%. My issue is that the cruise air speed is set to 10m/s and its not even trying to get to 10m/s, just staying high speed with 40% throttle.

I will do the autocal of airspeed sensor soon. The plane is small (wing wing z84) so it doesnt need much power to go fast. The airspeed sensor tubes are straight and clean install.

Ive added a picture of ground speed vs air speed. I’m sure the speed is somewhat correct because i can see how fast it travels. Ive been using no airspeed sensor and throttle trim at 25% and seen the plane fly for weeks at 25% ~ 12m/s and its going much faster than that.

Stall speed is about 7m/s as this plane is small and light.

Should i change the TECS speed weighting and have more speed control rather than altitude control?

Do the autocal first as that will calibrate your airspeed properly, then try lowering your trim throttle 5% at a time while in flight in a large loiter while graphing your airspeed, that should give you some further result. You could also try a smaller prop or one with a lower pitch as small, light flying wings are quite efficient and often don’t require a lot of power.

Here is the airspeedratio plot from the airspeed auto calibration. Is this doing the right thing? I went into loiter at about 7:39 time log and stayed in loiter for a about 5-6 minutes. The value flattens out at about 2.66. Is this number okay?

I still have to decrease the throttle trim and do some testing but its raining the next two days. I have a 6x5 prop on, this gives me the best efficiency. I can get 45-50 minutes out of a 2200mah battery sitting on 25% throttle using only thottle % auto control, so Im trying to replicate this in auto mode with airspeed sensor control.

I wish the old throttle control autopilot method used a min ground speed parameter so it could adjust for wind.

So after further airspeed auto Cal the ratio is 2.26. I’m sure airspeed is accurate.

I managed to slow the plane down but it is not a true fix. Basically the only way to have any effect on the airspeed was to set the max airspeed. Ie I set it to 16m/s and the plane slowed to that speed. I continued in steps of 2m/s down to 8m/s and each speed was well maintained in loiter. The throttle dropped to only 17% for 8m/s so it is adjusting throttle right.

It’s as if the target air speed is always the max airspeed. Changing cruise air speed does nothing. I’m thinking of reinstalling software on the apm. Seems like a software glitch or something.

Any thoughts?

So after a lot of thought and checking parameters it turns out the MIN_GNDSPD_CM parameter was set to 9000 (90m/s) instead of 900, which was why the airspeed was always at max airspeed.

Thank you to those who tried to help out it was much appreciated!

1 Like