Aileron not working after upgrade to 3.8.0 stable from 3.8.0b5

After upgrading my skywalker to 3.8.0 stable my ailerons are acting like elevons or flaps I’m not really sure you roll left and both ailerons go up, you roll right and both ailerons go down. Am I missing something after this upgrade. RCMAP is AETR, I read that using elevons is much easier now because you just set params to elevons and then reverse ect. but my servo 1 is set to 4 with is ailerons i went through all of them and everything was working to a top! Could this be related to my transmitter although i tried it in FBWA and everything but the ailerons work, rudder, elevator all correct in manual and FBWA but ailerons.
I have attached both a working 3.8.0b5 and a 3.8.0 stable param file. I hope im missng something, finally got companion computer and qx1 firing, working on reach rtk now but can live with GCP’s. Also have some amazing 6s lithium ion batts that are ready for hopefully dependant on conditions 1.5hr to 2.5hr. next step is auto takeoff and autoland (autoland using lidar, of course)
MC_skywalker_3.8.0beta5.param (14.4 KB)
Iskywalker_081917_badail.param (14.4 KB)

Here is a short video of how my ailerons are working, I have even reverted back to my old beta 5 format and they are still causing a problem. At this point I am at a loss of how to solve this might move ailerons to another connection and see if that helps, have reprogrammed my radio to see if that was the issue but it was not. Could I have shorted something out and messed up the pixhawk or do i need to have left and right servos.
Bad Ailerons

Is anyone else having this same issue, last night i completely wiped my pixhawk 2 and installed rover then reinstalled plane also switched my aileron y from main 1 to main 5 and set function to 4, same thing happens they both move the same direction. working skywalker 3.8.0b5 I have added a video of its first flight on 3.8.0b5, have also reverted back to that setup and ailerons are still not functioning.

@anon94298870 SERVO4_FUNCTION is set to 21, which means its treating the output 4 as a rudder.

thanks for the reply I will check it out at lunch today, so many functions to double check I must have totally overlooked that one, always nice to have a fresh set of eyes to double check things! Appreciate the help good Sir!!!

No worries, a lot changed with the RC/SERVO functions/splits, you’ve probably seen it already but if not giving this a peruse: will be worthwhile

After looking over my param, it is all setup correctly, but still not funtioning properly. I have included a copy of my taranis setup so I know I am not going crazy, I even setup a new model just to make sure I didnt change anything on accident. To add more context to this issue, my RCMAP is set to be AETR, as is my skywalker,skywalker 2 taranis setup. so SERVO1_FUNCTION set to 4, SERVO2_FUNCTION set to 19, SERVO3_FUNCTIONset to 70, and SERVO4_FUNCTION set to 2. (8.4 KB)
I have gone as far as installing rover firmware on it then reinstalling plane, and setting it up with all new params using the same stuff as described above. I also have set servo 1 to disable and installed my y for my ailerons into servo 6 and set servo 6 function to 4. could it be something with not having right and left servos or something simple like that, I will have to check and see what brand I am using they might be savox or some other brand like emax. I cannot for the life of me figure this out!! Should I be not using a Y and just setting two servo_functions to 4 and reverse one? like servo1_function to 4 and servo6_function to 4 and hooking up each wing side individually to the pixhawk?

I was able to solve my aileron problem but it seems odd to me that I now have to use 2 main ports for my ailerons Main 1 and 6, main 5 has a camera lenses cover on it. Basically I set up 2 channels on my pixhawk 2.1 as ailerons put rc in manual and reversed the correct servo to make sure it was operating in the correct fashion, then put it in FBWA and made sure it corrected the control surfaces to bring it back to level. Why now do I have to use 2 main ports to get my ailerons working correctly when I use to get away with just using a Y to connect all ailerons on on main port? Again am I just missing something I have read and re-read everything, also tried setting them up as flaperons using the Y but the still acted the same as mentioned earlier.

this doesn’t really make any sense. When using a Y lead the autopilot doesn’t even know you have two servos - it is outputting a single signal. If you can’t use a Y lead now, then there is no way you could have been using a Y lead previously. There has to be a physical change in the aircraft (eg. changing orientation of a servo in a wing, or changing servo programming to make it reverse).
Cheers, Tridge

1 Like

It was a new set of wings so I believe you solved the problem, I guarantee it is because one of the servo orientations has changed. I was wondering if that was the issue but didn’t realize that would cause it to act that way. Do you think using a Y is not a good idea and two outputs would be better option?

two outputs is fine, just make sure you have the trim and ranges right for both servos