Servers by jDrones

AHRS_CUSTOM with Plane 3.9.8 and Matek F405

(Andreas) #1

Hey,
I’m just setting up a brand new Matek F405Std with Plane 3.9.8. Because of space considerations I want to mount the board in a non standard orientation into my plane. So I changed these parameters:
AHRS_ORIENTATION 100
AHRS_CUSTOM_PIT 90
AHRS_CUSTOM_YAW 90
After saving and power cycle, the artificial horizon shows nose down of about 25 to 30 degree while holding the controller level in my planes orientation.
Before, with default parameters, it showed perfectly leveled in default orientation.

I already did a similar procedure with another setup and had no issues. So I’m wondering, did I miss something or is it a serious bug?
All other parameters have their defaults, it also doesn’t matter if I run the sensor calibration or not.

Thanks for any hints in advance!

(Andreas) #2

Btw. same behavior is in ArduPlane 3.9.9 Beta from yesterday.
Just played around with other settings and found, I’m also getting what I want with:
AHRS_ORIENTATION 30
So for the moment I’m happy with that, however I think somebody of the developers should take a look on it.