After upgrade from copter 4.1.5 to 4.3.2 no position estimate

I upgraded my 9’’ test quad from 4.1.5 to 4.3.2 but after upgrade FC can’t get position estimation and all navigation modes stopped working.
GPS module is the same and still communicates, compass was recalibrated, but still something wrong with the position.
After restoring 4.1.5 it works again perfectly. Does anyone give me a hint what can be wrong?
Light 9’’ quad "similar to DJI Phantom, 960kV motors, Omnibus F4V3, VK2828U8G5LF GPS.
Log is here.

You have to wait until you see these messages (one IMU with that Flight Controller):

and (optionally)

With the Fence setting, you WILL NOT be able to arm and fly in ANY mode until there is a good GPS 3D fix and Home can be set.
This avoids the issue of flying and modes being rejected because you dont have a good 3D fix or no Home position set. Those conditions lead to trouble, like:

  • copter heads to Sea of Japan when RTL is required
  • you think your are in Loiter and you are not, copter drifts with wind
  • tip-over at launch due to wandering GPS position

Sometimes the firmware updates improve reporting and messages, so the condition may have existed before and you were not aware of it.

I understand and accept risks I undergo having disabled safety features.This is really test only copter and I fly it only around my head.
So conclusion is that I had bad GPS position? With 3D fix, 12 sattelites and HDOP 0,79? That sounds strange to me.
Can somebody really discover why position wasn’t OK?

Yes I would say the GPS position is bad.
In this pic from your log, you’ve launched by line 12198 and dont have a valid position
And for the rest of the flight you still dont have a valid position, mode changes are rejected, lines 20648, 27634 and 34467

I see that you do get a good HDOP and number of sats, but the whole log of the flight is only just over 3 minutes. If this was the first of the day it can take quite some time for the GPS position to settle and be valid. I would say that you should definitely set ARMING_CHECK,1 as this is possibly causing some issue we’re not seeing.

If you dont like setting FENCE because it seems too restrictive, then you should select Loiter mode once powered up and wait for the “green light”, then select whatever mode you like and launch. In reality this is exactly the same as setting the FENCE_ENABLE param but leaves you open to human error, or the choice to fly in non-position-controlled modes and ignore the errors.
It is hard for small quads to get a good GPS fix while on the ground, being so low…

I believe it’s a common mistake to think “this is only for testing” and I’ve been there too.
Having the correct settings is often more important in testing, and work through any issues that come up.
Once everything is nailed down and the copter is a “known quantity” then start changing things for GPS-denied flights or disabling battery failsafes.


Sure, wait longer.

1 Like